Broken Insyde-Bios Acer Aspire 4820TG

Jun 12, 2019
1
0
10
Best answers
0
Ladies & gentlemen,

I interrupted a BIOS update and probably destroyed my Insyde BIOS. So I tried to do a BIOS recovery with different tutorials (for example https://www.bios-mods.com/bios-recovery/), but it did not work.

Model: AS4820TG
Product Name: Acer Aspire 4820TG-434G50Mn
BIOS Chip: bios-chip24

I have performed the following steps:

1.I got the correct BIOS file from the Acer website (BIOS_Acer_1.15_Windows.zip).
2.I unzipped BIOS_Acer_1.15_Windows.zip, came out the following files:
BIOS_Acer_1.15_Windows.zip \ DOS \ ZQ1_115.exe
BIOS_Acer_1.15_Windows.zip \ Windows \ ZQ1_115W.exe
3.I unzipped the ZQ1_115W.exe, came out the following files:
AtpTimerInfo.dll
ding.wav
FWUpdLcl.exe
InsydeFlash.exe
iscflash.dll
iscflash.sys
iscflashx64.sys
Platform.ini
xerces c_2_7.dll
ZQ1x64.fd
4.I formatted a 2GB USB stick with FAT.
5.I copied the file ZQ1x64.fd to the USB stick.
6.I have removed AC and the battery pack.
7.I connected the USB stick to the laptop.
8.I pressed FN + ESC and did not let go.
9.I have connected AC to the laptop.
10.I pressed the power button.
11.After 15 seconds the USB stick started to light up and I released FN + ESC.
12.The fan got louder. No beep. The screen switched between two blacks. The USB stick changes regularly between: 10-20 seconds light up, 3 - 4 times short flash, no light, 10-20 seconds light up... ...and so on.
13.I wait 10-30 minutes but nothing happens.
14.I turn off the laptop, remove the USB stick and turn on the laptop again.
15.I still do not get any output on the screen.

Did I made some mistakes? Or should I try another file? Or is there another solution without remove the chip?
I already tried every BIOS-file from the Acer homepage (v1.13-v1.25) and also a working and tested file from notebookreview. I also tried with ‘Windows’ key and the ‘B’ key. And i also used another USB Sticks.

Sorry for my poor English.

I dont have money for new hardware so i would be glad if someone can help me with this issue, very very thank you. :giggle:
 

Saga Lout

Glorious
Moderator
Mar 31, 2010
5,328
11
46,315
Best answers
1,839
You might like to try removing the CMOS battery form the motherboard. It's a small, shiny disk and it has a gap in the circle where you can carefully insert a small screwdriver or even a needle to trip it out of the container. Then power the machine down.

That holds the BIOS settings and details which have changed at some stage. Leave it out for a few minutes then replace it and power the machine up. With luck, the BIOS chip will start up and run normally, with the original settings.
 
Thread starter Similar threads Forum Replies Date
L Laptop General Discussion 0
D Laptop General Discussion 2
B Laptop General Discussion 0
C Laptop General Discussion 3
K Laptop General Discussion 1
L Laptop General Discussion 4
K Laptop General Discussion 2
R Laptop General Discussion 0
C Laptop General Discussion 1
M Laptop General Discussion 1
H Laptop General Discussion 2
V Laptop General Discussion 3
Lutfij Laptop General Discussion 0
B Laptop General Discussion 1
S Laptop General Discussion 1
M Laptop General Discussion 8
J Laptop General Discussion 1
R Laptop General Discussion 3
J Laptop General Discussion 2
N Laptop General Discussion 1

Similar threads


ASK THE COMMUNITY