Can't Connect via WiFi; Ethernet Connection Good.


Oct 4, 2012
Got a problem connecting via wifi to IZZI internet (Tijuana). This laptop still works fine on Starbucks' wifi here, so I know it's not the laptop. Also works with an ethernet cable to the modem. However, without the ethernet cable, even though wifi tells me it's connected & everything looks fine, when I try to go to any site, I get only error messages, such as:

This site can’t be reached’s server IP address could not be found.
Try running Windows Network Diagnostics.
There is no Internet connection

Checking the network cables, modem, and router
Reconnecting to Wi-Fi
Running Windows Network Diagnostics
Maybe it's something in my settings, but I don't know what. It has Avast antivirus on it.

Any help is appreciated. Thanks. :)

Try this....

1. Go to "Control Panel".

2. Next go to "Network and Internet" and then "Network and Sharing".

3. Now click on "Manage Wireless Networks".

4. On this screen, remove all wireless connections by "right clicking" on it and select "Remove network" from the drop down menu.

5. After doing this, close the open windows and reboot the computer.

6. Once the computer is fully reloaded, scan for the "WiFi networks".

7. Click on the available network that you want to access and select "connect".

8. It takes a moment, but then you will be asked to give a password for your WiFi connection. Type in the password and click the "connect" button.

It should now be connected.

NOTE: If this doesn't work, you may want to reset your modem/router, and then once it is fully loaded again, repeat the above steps.

If this doesn't work, test seeing if your laptop will connect via Ethernet. If so, then your WiFi card may be going. You can either look to replace it/have it replaced, or get an external (plugs in via USB) WiFi card.

Another way to try it is to...

1. Go to "Settings".
2. Click on "Network & Security" and then click on "WiFi".
3. Now click "Manage known networks".
4. Select the WiFi connection you want to remove.
5. Click the "Forget" button.
6. After doing this, close the open windows and reboot the computer.
7. Once the computer is fully reloaded again go to "Settings".
8. Click on "Network & Security" and then click on "WiFi".
9. Now click "Manage known networks".
10. Click "Add a new network" and enter the network name.
11. Using the drop-down menu, select the "network security type".
12. Check the "Connect automatically" option.
13. Now check the "Connect even if the network is not broadcasting" option and click "Save".

Once you have completed these steps, whenever the device is within range of that particular network, it should automatically connect to it.


Mar 3, 2017
I agree with webworkings that this does sound like a wireless networking/Windows issue, considering you have no problems connecting to the Internet with Ethernet. In other words, Avast shouldn't be affecting this :) But we're to help if you have any questions for us, and we thank you for being a fan!

Some versions of Avast do have a feature called Real Site which is designed to create an encrypted connection between your machine and Avast's own DNS servers to prevent DNS hijacking, but this shouldn't cause any issues with connectivity on your personal machine.
Thread starter Similar threads Forum Replies Date
RaCors Laptop Tech Support 1
S Laptop Tech Support 3
D Laptop Tech Support 2
S Laptop Tech Support 2
A Laptop Tech Support 5
F Laptop Tech Support 1
S Laptop Tech Support 1
P Laptop Tech Support 1
I Laptop Tech Support 1
M Laptop Tech Support 4
F Laptop Tech Support 6
L Laptop Tech Support 1
M Laptop Tech Support 1
Ordan Laptop Tech Support 3
S Laptop Tech Support 3
D Laptop Tech Support 3
R Laptop Tech Support 3
B Laptop Tech Support 3
T Laptop Tech Support 1
T Laptop Tech Support 8