Can't resize partitions with Disk Utility

Woody1999

Estimable
Jan 3, 2015
11
0
4,560
0
Hi, I have the 13-inch Mid-2014 MBP, with a 2.6GHz i5, 8GB of RAM and 120GB SSD. I'm running OSX Yosemite 10.10.3.

I'm trying to dual-boot Zorin OS 9 (a variation of Ubuntu) onto my MacBook, but I can't get past the first stage! When I load up Disk Utility and try and shrink my single partition (with 30GB of free space), everything is greyed out!

Here's a picture to help out: http://i.imgur.com/VnPBkhB.png

I need to simply shrink the partition a bit, so I have some unallocated space to install Zorin OS onto with rEFInd. I've already followed the advice in this article: http://awesometoast.com/yosemite-core-storage-and-partition-woes/ but it has had no effect on my situation. Does anyone know how to fix this?

Thanks in advance,

Woody
 

White The Legend

Estimable
Jun 21, 2015
1
0
4,520
1
Check out this link, I think it may be able to help you out: http://apple.stackexchange.com/questions/17901/how-can-i-resize-a-partition-with-disk-utility

When dealing with partitions on a PC I usually use AOMEI Partition Manager (Free Download: http://download.cnet.com/AOMEI-Partition-Assistant-Standard-Edition/3000-2248_4-75118871.html ) I've never heard of shrinking a partition because the data has to go somewhere. But with this software or any other Partition Managing software you should just be able to cut off a piece of a partition.
 

White The Legend

Estimable
Jun 21, 2015
1
0
4,520
1
Check out this link, I think it may be able to help you out: http://apple.stackexchange.com/questions/17901/how-can-i-resize-a-partition-with-disk-utility

When dealing with partitions on a PC I usually use AOMEI Partition Manager (Free Download: http://download.cnet.com/AOMEI-Partition-Assistant-Standard-Edition/3000-2248_4-75118871.html ) I've never heard of shrinking a partition because the data has to go somewhere. But with this software or any other Partition Managing software you should just be able to cut off a piece of a partition.
 

Woody1999

Estimable
Jan 3, 2015
11
0
4,560
0
I don't quite have the same problem, and I can't afford the time to clone the disk anyway.

Is there something up with my settings? I have FileVault enabled if that helps.

Woody
 

ASK THE COMMUNITY