Question Changing network hostname on Gosund switches?

Aug 4, 2022
2
0
10
0
I'm relatively new to home automation, but I'm jumping in with both feet. Currently I have 11 switches and plugs installed, all Espressif devices, mostly Gosund, controlled by SmartLife (and Alexa through the SmartLife skill).

Until yesterday, all the devices I've installed have shown up on the network with hostnames ESP_[last 6 chars of MAC], so for example a switch with MAC address bc:dd:c2:0c:44:3a would show up as hostname ESP_0C443A. All good so far. But I bought another 4-pack of Gosund switches and installed two of them yesterday, and they don't follow this standard. They both show up as wlan0:



I assume the other two will also show up as wlan0 when installed. It's not preventing them from working, but it's annoying to have multiple devices with the same hostname on the network.

Is it possible to change the network hostname? Each of these devices has a static lease assigned in DHCP, with the desired hostnames defined, but the devices don't seem to pick that up from DHCP. (Nor should they, really; that's not what DHCP is for.) I've googled for an answer on how to change the network hostname on these devices, but all the results are about how to set the device name in the app, which is a different thing. I can name a switch "Bedroom Lights" in the app just fine, but it's still wlan0 as far as the network is concerned.

Can this be done?
 

raykneale

Honorable
Oct 5, 2017
26
2
10,615
17
Hello
You should be able to edit client names on your routers home page ,I have a TP Link

AX6600 Tri-Band Wi-Fi 6 Router and looking under the Network tab ,and then Clients ,all my connected smart home gadgets are listed the same way as yours are ,there is a small pencil icon next to it ,which allows you to edit the namesof connected clients .Your router may be set up differently to mine but you should be able to find the right page with a little searching .
Good Luck .
Stay Safe.
 
Aug 4, 2022
2
0
10
0
Hello
You should be able to edit client names on your routers home page ,I have a TP Link

AX6600 Tri-Band Wi-Fi 6 Router and looking under the Network tab ,and then Clients ,all my connected smart home gadgets are listed the same way as yours are ,there is a small pencil icon next to it ,which allows you to edit the namesof connected clients .Your router may be set up differently to mine but you should be able to find the right page with a little searching .
Good Luck .
Stay Safe.
Hi Ray,

I appreciate the reply but that's not quite the situation. I have already changed the names of the devices at the router (actually a firewall/UTM in this case, but that's where this setting lives in my network). That causes them to display those names at the router, but as revealed by the access point's status screenshot, the actual hostname the devices are presenting to the network remains wlan0 for both. Changing them at the router basically just says, "Hey, you know that device at 10.80.4.31 that's calling itself wlan0? Pretend for me that it's calling itself ESP_0C443A instead."

When I set these two devices up, I had no problem with the first one, but significant difficulty with the second one; it took three tries to actually get it recognized, and I suspect the overlapping device hostnames had something to do with that.
 

ASK THE COMMUNITY