Constant buzzing/static noise in Sennheiser Game One headphones

the-gaming-alien

Estimable
Feb 23, 2015
2
0
4,510
0
Hi all, so this issue is driving me insane i've read countless similar forum posts but have not been able to find a solution.

So when i just start the PC and don't have much running the noise is not very loud at all, however when i start a game (any game) or do something intensive the noise gets MUCH louder.
If i drag a window across the screen or even move my mouse i'm able to hear the movement in the sound..

The noise stays even if i turn system volume to 0, it stays even if i completely disable my playback devices. The noise does go down if i change the volume on the headset itself (going away completely under 40%).

I'm running the Sennheiser Game One headset with a "Creative Sound Blaster Audigy FX PCIe 5.1" soundcard.

Hopefully someone out there is able to help me out as i'm slowly losing my sanity.
If you need any more info about my build please let me know.

Thank you.
 

dudio

Admirable
First test the headset on something else and rule it out.
I suspect it will turn out that it's fine. To me, it sounds like a grounding issue, from with the power outlet at the wall (that outlet has a poor ground), the power cord from there to the PC (the ground wire is bad..this could be tested by conductivity on a multimeter, or trying another cable-unlikely anyways), a bad powerbar/surge supressor (bypass it), or a faulty soundcard/drivers (you could try onboard sound to rule out), or the PSU is bad (what make is it?), or some kind of ground fault with the hardware in the tower.
 

the-gaming-alien

Estimable
Feb 23, 2015
2
0
4,510
0


Sorry, yes i should have mentioned in the post that i have tested it on other machines without the issue.

I am using a big extension lead and an old (but high quality) powerbar so i'll try bypass them and see if that changes anything. My PSU is the corsair CS650M.

Thanks for your help!
 

Similar threads