Content Creation software (PS, 3ds Max) recognizes dedicated GPU but is not utilizing it?

Kaoru_K

Commendable
Jan 18, 2017
1
0
1,510
0
I've recently bought the MSI GS40 6QE (16 GB RAM, i7-6700HQ, Intel(R) HD Graphics 530, NVIDIA Geforce GTX 970M, Win 7 Pro) and facing several problems with Photoshop and 3ds Max. Photoshop is recognizing the dedicated graphics card (thanks to the NVIDIA Control Panel) but is very slow at the startup and is actually running much smoother and faster without the GPU features activated. I already disabled the GPU sniffer or else it wouldn't even let me use the GPU features at all. 3ds Max will only run in the Nitrous software mode or else it will crash with an "Application Error". (Every game I tested works just fine with the NVIDIA graphics. I am also using ZBrush and it's working just fine.)

NVIDIA and Intel drivers are all up to date, already tried a clean installation of both. The BIOS is also up to date. The Energy Management and the whole NVIDIA Control Panel is set to maximum performance. Both Photoshop CC 2017 and 3ds Max 2017 are up to date.

Is Windows 7 causing all that trouble? Please let me know your thoughts and ideas how to fix that.
 
Thread starter Similar threads Forum Replies Date
C Laptop Tech Support 7
raintop Laptop Tech Support 2
K Laptop Tech Support 1
T Laptop Tech Support 3
J Laptop Tech Support 7
Sean_34 Laptop Tech Support 3
T Laptop Tech Support 1
D Laptop Tech Support 1
B Laptop Tech Support 6
D Laptop Tech Support 7
K Laptop Tech Support 2
P Laptop Tech Support 1
A Laptop Tech Support 2
B Laptop Tech Support 1
F Laptop Tech Support 2
C Laptop Tech Support 1
D Laptop Tech Support 2
F Laptop Tech Support 1
G Laptop Tech Support 1
L Laptop Tech Support 2

ASK THE COMMUNITY