Question My laptop refuses to use dedicated Nvidia GPU for games

May 10, 2019
2
0
10
0
Operating System: Windows 10 Home 64-bit (10.0, Build 17134)(17134.rs4_release.180410-1804)
System Manufacturer: Acer
System Model: Aspire V3-571G
Processor: Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz (8 CPUs), ~2.4GHz
Memory: 16384MB RAM
Intel(R) HD Graphics 4000
NVIDIA GeForce GT 730M


I've been searching for the past few days for a solution, to no avail. I've gone through forums, videos and guides. Nothing works.

In the Nvidia control panel i've set the dedicated GPU as the global preferred and also tried setting it for each game separately in the program settings tab. In the PhysX config I set the Nvidia GPU as the preferred one. I've also tried running each program as admin and I've tried choosing the GPU the program should use from the drop down menu when you right click. I also tried disabling the driver from device manager. That did seemingly fix the problem, but caused a slew of other problems, like video players not working and chrome becoming sluggish. So i reverted that. I also tried to do the same thing through BIOS, but I couldn't find an option there to do it. I also reinstalled the nvidia driver from their website, but that didn't do anything.

I have shut down and restarted the laptop many times in the process of trying to fix the issue

The 2 main ways i check which GPU a game is using is either through the game itself, since some games say which GPU they are using, like stonehearth. Or i check the Nvidia GPU activity log.


To sum it up:

Laptop wont use dedicated Nvidia GPU, instead uses integrated Intel GPU. Tried everything i can think of.
 
Did you try the following?

First, uninstall, and then reinstall, the latest graphics card driver.

Then try these steps on how to set it to default.

  1. Open the "Nvidia Control Panel".
  2. Select "Manage 3D Settings" under 3D Settings.
  3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
  4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance Nvidia processor.
Once it is running on the right one, test the system again and see if the problem persists.
 
Reactions: Kamber
May 10, 2019
2
0
10
0
So, I had done the thing from the nvidia control panel multiple times but it never seemed to work. I had also reinstalled the NVIDIA driver, but that didnt work either. So nothing seemed to work.But the one thing I didn't think could be the problem was the INTEL driver, since the problem seemed to be on the side of NVIDIA. And futhermore since I have a program(drivermax) that should install the latest drivers for me. And it seemingly worked fine, had updates on the regular and it recently had updated the INTEL driver. So that was the last thing on my mind. But, your reply was the wake up call. Why not try to find the intel driver myself and update it. And lo and behold there was an update, good god. I had low hopes, didn't want to get dissapointed. But when I ran a game after the update, the NVIDIA GPU activty log lit up and everything seemed to work now.
So thank you. I guess sometimes you need somebody else to say the obvious.

In short:
Reinstalled Intel driver myself to fix the issue
 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 4
R Laptop Tech Support 3
A Laptop Tech Support 5
A Laptop Tech Support 1
I Laptop Tech Support 3
M Laptop Tech Support 1
W Laptop Tech Support 1
BlueWidow Laptop Tech Support 3
A Laptop Tech Support 1
B Laptop Tech Support 3
H Laptop Tech Support 5
Myronazz Laptop Tech Support 4
Kerochii64 Laptop Tech Support 1
N Laptop Tech Support 1
Z Laptop Tech Support 1
Q Laptop Tech Support 1
B Laptop Tech Support 1
C Laptop Tech Support 5
M Laptop Tech Support 18
T Laptop Tech Support 2

ASK THE COMMUNITY