Solved! Dell G7 15 7588 problem

Apr 26, 2019
6
0
10
0
Hi, recently i bought dell g7 7588

i7 8750h
16gb ram
1050 ti
1tb hdd
250 ssd

i just noticed i got 130w ac adapter instead of 180w, now my problem is my gpu doesn't get enough power or its my gpu faulty? Below are the user benchmark that i tested.

idk if this a glitch or what but i tried uninstalling the gpu driver and not restart but instantly reinstall the driver and the result is the gpu back to what it should be
https://www.userbenchmark.com/UserRun/16498809

then i tried unplug the ac adapter and put it back then run the benchmark. The gpu back to its worst state which i can't even gaming.
https://www.userbenchmark.com/UserRun/16498089

same result whenever i got the glitch and instantly restart the laptop its back to the low score gpu.

need some expert to explain it that it's the ac adapter problem or the gpu thanks.
 

Saga Lout

Glorious
Moderator
It is almost certainly caused by lack of power and sooner or later, the whole machine will slow down and fail. Look at the printing on the battery and make sure you but a genuine power charger which mA match the battery.

Search eBay but be prepared to spend good money for the right charger. Some cheap Chinese units may just be cones and have been known to fail or worse, cause fires.
 
Apr 26, 2019
6
0
10
0
It is almost certainly caused by lack of power and sooner or later, the whole machine will slow down and fail. Look at the printing on the battery and make sure you but a genuine power charger which mA match the battery.

Search eBay but be prepared to spend good money for the right charger. Some cheap Chinese units may just be cones and have been known to fail or worse, cause fires.
I use ac adapter comes with the laptop so it's genuine.
btw i got this msg whenever i plug in the charger.



if it is truly because of ac adapter then why the heck dell give 130w ac adapter instead of 180w
i just wanted to confirm this thanks in advance.

edit: i'm monitoring the gpu using gpu-z and whenever i tried to gaming the gpu perfcap is change from idle to pwr instantly

this is when i tried gaming the gpu clock throttled but the gpu/cpu temp are not high

 
Last edited:

Saga Lout

Glorious
Moderator
I am amazed and informed. The unit connected to this laptop has a Watts figure of 45. It must be something to do with the difference in Voltage out of the wall in the States compared with England. That said, I still don't understand how two such dfferent figures work the same machine.

I must seek help and therapy from my American members of Tom's Moderation Team.
 
Reactions: Doraneko41
Apr 26, 2019
6
0
10
0
I am amazed and informed. The unit connected to this laptop has a Watts figure of 45. It must be something to do with the difference in Voltage out of the wall in the States compared with England. That said, I still don't understand how two such dfferent figures work the same machine.

I must seek help and therapy from my American members of Tom's Moderation Team.
Thanks for your information

The higher wattage PSU is needed for this Dell. My Mobile Precision does the same. All should be well with the 180w variant.
Tq very much!
 
Thread starter Similar threads Forum Replies Date
G Laptop Tech Support 3
N Laptop Tech Support 1
V Laptop Tech Support 1
moekun Laptop Tech Support 9
MustersGas001 Laptop Tech Support 7
nik19981998 Laptop Tech Support 1
I Laptop Tech Support 6
DPick33 Laptop Tech Support 0
G Laptop Tech Support 1
W Laptop Tech Support 1
TommyInfinity Laptop Tech Support 9
S Laptop Tech Support 4
Paladin54 Laptop Tech Support 4
kirito99issei Laptop Tech Support 4
WilliamLacy Laptop Tech Support 1
K Laptop Tech Support 0
Aeschylus Laptop Tech Support 6
M Laptop Tech Support 0
S Laptop Tech Support 0
S Laptop Tech Support 4

Similar threads


ASK THE COMMUNITY

TRENDING THREADS