Dell Latitude E6420 Plugged In Not Charging

Catbugmau5

Prominent
Feb 18, 2017
1
0
510
0
Hey all,
Having the dreaded plugged in, not charging issue.

What I've done so far:
Compressed air to clean port and adapter
Checked under the hood to make sure connections were all there
Have up to date BIOS
Unplugged and cleaned battery connections

Any ideas?
 
Have you tried charging when it is turned off to see if it will charge then? If it does, it may well be the charger cord that is the problem.

If not, then I would suggest you may need a new battery. Either that or the charging circuit on the motherboard may be damaged. Should that be the case, then you may have to replace the motherboard.
 
Have you tried charging when it is turned off to see if it will charge then? If it does, it may well be the charger cord that is the problem.

If not, then I would suggest you may need a new battery. Either that or the charging circuit on the motherboard may be damaged. Should that be the case, then you may have to replace the motherboard.
 
Thread starter Similar threads Forum Replies Date
Enjoying Laptop Tech Support 1
D Laptop Tech Support 0
Dzoelx Laptop Tech Support 0
Sushisusi Laptop Tech Support 1
R Laptop Tech Support 6
P Laptop Tech Support 1
A Laptop Tech Support 1
P Laptop Tech Support 1
muppet92 Laptop Tech Support 0
Ahmad-PC- Laptop Tech Support 2
I Laptop Tech Support 0
A Laptop Tech Support 1
L Laptop Tech Support 3
R Laptop Tech Support 1
C Laptop Tech Support 3
S Laptop Tech Support 6
Boris_yo Laptop Tech Support 1
M Laptop Tech Support 4
H Laptop Tech Support 3
kingneptune117 Laptop Tech Support 5

ASK THE COMMUNITY