Solved! Discrete GPU not being used?

Jan 2, 2019
1
0
10
0
I have a laptop with a gtx 1050ti 4 gb, 8 gb of ram, and an i7-8750H cpu, those are well above the recommended requirments for fortnite and a lot of other games, yet, in fortnite for example, i can barely maintain 60 fps on the lowest settings, I think this might be because my laptop could be using my integrated graphics instead of my [strike]dedicated[/strike] discrete gpu, but im not sure, when i tried disabling the on board graphics completely from the device manager, I was not able to run any games and they barely even launched.
 

Phillip Corcoran

Splendid
Moderator


You must not disable the integrated GPU on a laptop.

What you need to do is configure each game so it uses the GeForce GPU --- usually configured in 3D Settings in Nvidia Control Panel. If it's a new laptop however, that method may no longer be valid but it certainly was when I had a laptop four years ago.

If you don't do the above, all your games will use the weaker Intel GPU by default.
 
Jan 2, 2019
2
0
10
0
MERGED QUESTION
Question from famoustnt : "GPU not being used?"

I have a laptop with a gtx 1050ti 4 gb, 8 gb of ram, and an i7-8750H cpu, those are well above the recommended requirments for fortnite and a lot of other games, yet, in fortnite for example, i can barely maintain 60 fps on the lowest settings, I think this might be because my laptop could be using my integrated graphics instead of my dedicated gpu, but im not sure, when i tried disabling the on board graphics completely from the device manager, I was not able to run any games and they barely even launched.
 

Lutfij

Splendid
Moderator
Clearly you're both the same person. So please quit with the multi account's and stick to one thread, meaning only of you responds. I'll shut down the account that you choose is unnecessary.

Consider this a public warning.


That being said, make sure your laptop is on the latest BIOS update. Then try uninstalling and reinstalling your Nvidia GPU drivers. You also forgot to mention the make and model of your laptop.
 

Phillip Corcoran

Splendid
Moderator


You must not disable the integrated GPU on a laptop.

What you need to do is configure each game so it uses the GeForce GPU --- usually configured in 3D Settings in Nvidia Control Panel. If it's a new laptop however, that method may no longer be valid but it certainly was when I had a laptop four years ago.

If you don't do the above, all your games will use the weaker Intel GPU by default.
 
Jan 2, 2019
2
0
10
0


Sorry, I didn't mean to spam accounts, but the first account I accidentally used my wrong email and I even requested its deletion before creating the second one. my laptop is a hp pavilion, not sure which model though. I will do what you said and reply with the results, thanks
 
Thread starter Similar threads Forum Replies Date
S Laptop Tech Support 0
Seric(98) Laptop Tech Support 4
DonTrePlays Laptop Tech Support 2
S Laptop Tech Support 0
L Laptop Tech Support 6
C Laptop Tech Support 1
N Laptop Tech Support 2
A Laptop Tech Support 1
rgs80074 Laptop Tech Support 6
B Laptop Tech Support 1
J Laptop Tech Support 2
A Laptop Tech Support 1
wicked_sticky Laptop Tech Support 5
S Laptop Tech Support 12
Lycaone Laptop Tech Support 7
R Laptop Tech Support 3
D Laptop Tech Support 5
R Laptop Tech Support 1
L Laptop Tech Support 1
X Laptop Tech Support 1

ASK THE COMMUNITY