Display port to hdmi doesn’t give me a picture on display.

RedHaze1911

Estimable
Aug 10, 2015
3
0
4,510
0
So I used a 1080p dp-hdmi adapter to get a picture to my 4k tv since my gpu’s hdmi port was used for my oculus rift. The adapter broke and I bought a new one. Didn’t give me a picture. Windows started loading and I can’t see the login screen. Started flashing green every 30 seconds or so. So I figured it’s a bad adapter or it’s a passive one. Got a new one that’s active from club3D. Doesn’t flash green anymore but just stays black after windows 10 loads. Can’t see the login screen. So I took out the oculus from the hdmi and still the same. It simply doesn’t deliver a picture from the gpu DP to my tv anymore. No idea why. Can’t use the DP for the oculus either cause it starts flashing black and white.
Only thing I can think of is that I did take out my hdmi from my gpu while the pc was working once. It started disk repair after I connected the hdmi to the dp and oculus to the gpu hdmi. But it works fine with the hdmi in the gpu hdmi port. I just can’t plug my tv to the dp-hdmi adapter. I also rolled back my gpu drivers to the previous version,no luck. This just suddenly started happening after I unplugged my HDMI to try the new dp-hdmi adapter. Everything worked fine before for months. Why is the world so cruel? If anyone can advise,I will appreciate it deeply.

4,5ghz 6700k,2x 980ti,16gb ram,Windows 10 64bit
And the adapter is a 26€ club3d active 4k one.
 

AniChatt

Honorable
Apr 1, 2013
18
0
10,570
2
Pls clarify it. have you checked your GPU is providing signal through hdmi/display port or not? of course without any adapter? Have you checked it with another monitor not tv?
Pls follow the steps,
1. If you have any monitor then connect it directly.
2. try it with different cable
3. try it without sli please sli is super crappy some times.
4. try in one gpu at a time.
 

4745454b

Distinguished
Moderator
Apr 29, 2006
605
0
19,210
77
MERGED QUESTION
Question from RedHaze1911 : "Display port to hdmi doesn’t give me a picture on display."



 

RedHaze1911

Estimable
Aug 10, 2015
3
0
4,510
0


Well I mean,it loads the bios,I can see the option to go into the bios and I can see the bios menu fine. But if I either don’t go into the bios or exit the bios,windows will start the loading screen and then goes dark. No signal. The tv just says HDMI 1 and the pc isn’t responsive. I tried pressing enter and entering the password to see if the pc is working but not displaying the picture but it won’t even load. I’d know because if I would have entered the password and it would load the desktop,my leds would start flashing. So it simply doesn’t get a signal I guess. Is there a better way to check it?
 

AniChatt

Honorable
Apr 1, 2013
18
0
10,570
2
If you have anything else to connect the pc i mean monitor? If not then pls try to connect the cable in your mobos hdmi/display port not gpus just to check if the problem with gpu output but you may not get any display and im not very sure on this.
2. Remove a gpu from your mobo and check it with a single gpu installed at a time.
But I think your gpu is working may be driver issue. Test it without sli and single gpu config
 

RedHaze1911

Estimable
Aug 10, 2015
3
0
4,510
0


Ok so what i tried was switching out the gpu's,didnt help. Now it Does say "no signal" on my TV. And i dont have a second monitor to test with. Also updated the drivers,still no luck. I shut down the pc and placed the hdmi cable into the mobos port and that also gave me no signal. Idk if im supposed to change something in control panel to make it use the mobo,or do i have to take out the gpu's?
Anyway... im losing hope here. Another weird thing started happening after i switched out the gpu's. I enter the login password and it doesnt go to the desktop but asks me to enter the pass again. Not every time but its happened 3 times now during restarts. Also disabled SLI and nothing.
The only thing that comes to mind is either try using a display port,for which i have no cable,or reinstalling windows because it Did do a repair disk after i just took out the hdmi while the pc was still working. I mean when i restarted the pc,it did a disk repair. Perhaps that screwed something up. Or i wonder if rolling back windows to a few weeks back might help? I feel like thats unlikely.
Any ideas?
 

AniChatt

Honorable
Apr 1, 2013
18
0
10,570
2

Does windows safe mode is working? Go to safe mode by pressing shift+restart button from windows menu.
 
Thread starter Similar threads Forum Replies Date
adimov Virtual Reality/Augmented Reality 0
ahkeem09 Virtual Reality/Augmented Reality 14
L Virtual Reality/Augmented Reality 1
G Virtual Reality/Augmented Reality 0
J Virtual Reality/Augmented Reality 3
V Virtual Reality/Augmented Reality 1
O Virtual Reality/Augmented Reality 2
M Virtual Reality/Augmented Reality 2
B Virtual Reality/Augmented Reality 0
A Virtual Reality/Augmented Reality 3
cratose99 Virtual Reality/Augmented Reality 10
cratose99 Virtual Reality/Augmented Reality 3
M Virtual Reality/Augmented Reality 1
N Virtual Reality/Augmented Reality 0
T Virtual Reality/Augmented Reality 1
fudgecakes99 Virtual Reality/Augmented Reality 1
Mark Spoonauer Virtual Reality/Augmented Reality 2
Mike Andronico Virtual Reality/Augmented Reality 1
CherlynnLow Virtual Reality/Augmented Reality 1
CherlynnLow Virtual Reality/Augmented Reality 3

ASK THE COMMUNITY