Fix Aptio setup utility loop? Asus F550C

Florian_11

Prominent
Feb 20, 2017
2
0
510
0
Heya,

Yesterday I've hit restart and update, but this didn't seem to progress.

Because a man needs sleep, I figured I'd just hard turned it off and this morning it seemed that I may have broken a thing or two.

I tried booting my laptop, again didn't progress as it was initializing the update, turned it off and now I'm stuck in the Apatio setup Utility loop.

I have read several other topics on how to solve this issue but enabling launch CSM and disabling Secure Boot Control aren't doing the trick for me unfortunately. It just keeps me in the loop.

Specs of my laptop are
Asus F550C
Originally OS W8 but upgraded to W10

Not sure what else I should specify but I'll happily add more if needed.

Thank you in advance
 

willleach

Prominent
Feb 21, 2017
4
0
510
0
I managed to fix a similar problem on my ASUS which was stuck at the BIOS screen.

None of the other suggestions worked (about changing BIOS settings or pressing F8 whilst booting) but this did:

Unplug the power and drain the battery fully to 0 charge. (alternatively if you can remove the battery, this should work).

Once its full de-powered, hold down the power button for 30 seconds to flush any staic from the unit. then reconnect the power and try powering up whilst holding F8. I kept holding F8 until windows launched.

Now the unit is back to normal. Hope this helps someone!
 
Thread starter Similar threads Forum Replies Date
F Laptop Tech Support 5
SnackinMcCracken Laptop Tech Support 1
S Laptop Tech Support 1
H Laptop Tech Support 3
N Laptop Tech Support 2
R Laptop Tech Support 1
P Laptop Tech Support 1
O Laptop Tech Support 1
D Laptop Tech Support 1
P Laptop Tech Support 2
L Laptop Tech Support 1
P Laptop Tech Support 1
D Laptop Tech Support 1
L Laptop Tech Support 1
C Laptop Tech Support 1
L Laptop Tech Support 3
M Laptop Tech Support 2
M Laptop Tech Support 1
R Laptop Tech Support 1
K Laptop Tech Support 1

ASK THE COMMUNITY

TRENDING THREADS