Flash firmware Samsung Galaxy S6

Feb 3, 2019
2
0
10
0
Began a lease of Samsung Galaxy S6 in Nov 2015. Phone bricked during an update in March 2017. Sent to Sprint for repair, was delivered a different Galaxy S6 phone, which was clearly refurbished itself, two weeks later. Lease completed, I own the device. Out of warranty.

Nov 2018 phone began showing "media device disconnected" message. Moments later the phone shuts off. There is no media device to disconnect. No Bluetooth speakers. No headphones. Nada. If it's an app causing the problem, I can't get the phone to stay on long enough to check it and get rid of it.

Battery suddenly reads 0% charged, although it was just at a much higher charge level, 40-60-80 to 90% charged before the disconnect message. Sometimes the battery doesn't actually lose it's charge at all. Many times I have to wait for the phone to completely recharge.

Used Safe Mode. Same message, same sudden shutdown.
Tried clearing cache. Nada.
Did a factory reset. Phone seemed to react well, began installing files and apps from my backups, suddenly the media device disconnected message began appearing at shorter and shorter intervals.

Phone is now "soft bricked". All it does is the boot/ shutdown loop over and over and over again.

From what I'm reading online, it's worth a try to flash the phone's firmware. Problem is, I don't trust the sites that offer Odin - which I don't know how to use anyway, or some of the other software I'd need.

Yes, I can take the phone to a repair shop, fork over $$$ to see if they can repair it, but ...

Does anyone know how to flash firmware on Galaxy S6 Android phones?
 

Saga Lout

Glorious
Moderator
The only website I trust on matters such as these is www.xda-developers.com for the advice and the .apk files to do the job.

The problem is that after the factory reset, the USB Debugging setting has probably been defaulted. Try slaving it to a PC and see if you can transfer between the two devices. If you can't, it's bad news and the next step will be another factory reset but this time, without any of your old data until you can make it fly in a basic state.
 
Feb 3, 2019
2
0
10
0


Thanks for the link and for responding to my problem.

My PC may be the root of why firmware flash isn't working. PC's running Win 7 Pro. Someone suggested I get on a Win 10 PC and the process might work. Will give it a try.

 
Thread starter Similar threads Forum Replies Date
R Android Smartphones 1
D Android Smartphones 2
D Android Smartphones 1
C Android Smartphones 1
C Android Smartphones 2
B Android Smartphones 1
B Android Smartphones 1
E Android Smartphones 1
R Android Smartphones 4
M Android Smartphones 1
P Android Smartphones 1
S Android Smartphones 1
D Android Smartphones 2
A Android Smartphones 1
O Android Smartphones 1
K Android Smartphones 1
N Android Smartphones 1
K Android Smartphones 1
D Android Smartphones 1
S Android Smartphones 5

Similar threads


ASK THE COMMUNITY