Friend's Razer Kraken Pro's mic echoing??

Quasty

Honorable
Jan 4, 2014
2
0
10,510
0
Hi there, my friend recently got a razer kraken pro, and ever since he got it i hear my voice about a couple of seconds delayed when talking to him, which is really annoying. He can't figure out how to fix it, so please help!!! (Also: it's only my voice im hearing, i dont hear his game music)


Thanks
 

darkbreeze

Honorable
Moderator
Did you eliminate all these already?

- Be sure the microphone is fully extended when in use. If you try to use the mic in the stored position you will pick up sounds from your speakers.

- Ensure that ""Listen to this device"" is not selected under Control Panel >Sound > Recording > Properties > Listen

- Check that your sensitivity levels are not set to max or boosted too much under Control Panel >Sound > Recording > Properties > Levels

- Ensure that only one voice chat application is in use while in-game

- Check that you are configured to use the proper microphone under Control Panel >Sound > Recording > Select proper Microphone > Set Default Device/Communications Device

- Ensure your computer supports the combined audio jack. If not, please use the included audio/mic splitter cable.


I've seen this before on some units that had audio jacks that were not the "combined" type. You might want to verify with your case or motherboard documentation. Maybe try the other jack, front or back, and see if the problem is resolved or exists on both.
 

darkbreeze

Honorable
Moderator
Is it a laptop? If so there may be a second, internal mic that is also enabled and is creating a sound loop or feedback that causes additional lag and echo. Not a very technical description I know, but I'd check the sound settings to make sure there are no other microphones enabled before trying other solutions.
 

Quasty

Honorable
Jan 4, 2014
2
0
10,510
0


Not a laptop. And yeah, its the only mic :/
 

darkbreeze

Honorable
Moderator
Did you eliminate all these already?

- Be sure the microphone is fully extended when in use. If you try to use the mic in the stored position you will pick up sounds from your speakers.

- Ensure that ""Listen to this device"" is not selected under Control Panel >Sound > Recording > Properties > Listen

- Check that your sensitivity levels are not set to max or boosted too much under Control Panel >Sound > Recording > Properties > Levels

- Ensure that only one voice chat application is in use while in-game

- Check that you are configured to use the proper microphone under Control Panel >Sound > Recording > Select proper Microphone > Set Default Device/Communications Device

- Ensure your computer supports the combined audio jack. If not, please use the included audio/mic splitter cable.


I've seen this before on some units that had audio jacks that were not the "combined" type. You might want to verify with your case or motherboard documentation. Maybe try the other jack, front or back, and see if the problem is resolved or exists on both.
 
Thread starter Similar threads Forum Replies Date
P Audio 0
R Audio 1
Gustas_ Audio 1
G Audio 1
Aggelabert Audio 1
U Audio 0
G Audio 1
M Audio 1
N Audio 1
RobotLizard Audio 6
K Audio 2
M Audio 8
S Audio 7
L Audio 2
I Audio 3
9 Audio 1
R Audio 1
G Audio 0
G Audio 0
WesleyT2 Audio 3

ASK THE COMMUNITY