Games open to a white screen unless it is opened with integrated graphic setting

Jul 15, 2018
2
0
10
0
I have a laptop with "Nvidia GeForce 940MX"
I used to play games on the laptop without a problem before but at some point certain games (more than one games) open to white screen. When I just click to play or even set it to high-performance nvidia setting the game screen stays white but the background music still plays along with the sound effect when I click something within the game. I have to keep setting the game to integrated graphics setting to be able to play properly but before I did not have to.

I want to able to play like before but I don't know how and when this started happening.

Please help~!

[Update] I can play in the old Nvidia driver but I can't in the latest one. The game runs smoothly in the old drive but it's like the new driver put a limiter.
 
You can also try the following...

Make sure that your Nvidia graphics card is set as the default graphics card.

Here's the steps on how to set it to default.

1. Open the "Nvidia Control Panel".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance Nvidia processor.

Once it is running on the right one, test the system again and see if the problem persists.
 
You can also try the following...

Make sure that your Nvidia graphics card is set as the default graphics card.

Here's the steps on how to set it to default.

1. Open the "Nvidia Control Panel".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance Nvidia processor.

Once it is running on the right one, test the system again and see if the problem persists.
 
Thread starter Similar threads Forum Replies Date
P Laptop Tech Support 0
NeedHelpGuy Laptop Tech Support 0
L Laptop Tech Support 8
Vladimira Laptop Tech Support 3
G Laptop Tech Support 1
S Laptop Tech Support 0
Gman9906 Laptop Tech Support 3
chaplark Laptop Tech Support 1
M Laptop Tech Support 0
T Laptop Tech Support 0
CptBaas Laptop Tech Support 0
T Laptop Tech Support 0
M Laptop Tech Support 3
awesomeballer69 Laptop Tech Support 1
K Laptop Tech Support 0
A Laptop Tech Support 7
E Laptop Tech Support 1
K Laptop Tech Support 3
J Laptop Tech Support 1
S Laptop Tech Support 5

ASK THE COMMUNITY

TRENDING THREADS