Games Suddenly Not Working.

Devassy

Honorable
Oct 23, 2013
1
0
10,510
0
Hi, I built an APU based system for my little brother about six months ago. He mainly plays games who aren't very taxing like Minecraft, Sims and Scribblenauts. The system has worked just fine up until a few days ago, when suddenly all the games stopped working. Whether its in steam or DRM-free, nothing works. Any other application is fine. Games, however, do not work.

Whenever you start one up, it just says it stopped working a few seconds after running the application. I was given an old HDD by a friend to install the OS on and at first I suspected that this was the culprit, which in my eyes still seems likely. It's old and makes a lot of noise.

I grabbed a second HDD out of my fathers old machine and tried installing games on that to see if that would help (I'm not much of an expert, but I thought it was worth a try). I've updated the BIOS to the current version, I reinstalled everything and cleared temp files along with some other miscelaneous tips I've gotten of the internet. Nothing has helped.

System specs are:
Asus F2A55-M mATX Motherboard
AMD A6-6400K with latest drivers
8GB DDR3 1600 mhz

Any help is appreciated.
 
Thread starter Similar threads Forum Replies Date
C Apps General Discussion 0
KloneCSGO Apps General Discussion 3
S Apps General Discussion 1
C Apps General Discussion 3
camarillodelrio Apps General Discussion 1
J Apps General Discussion 4
G Apps General Discussion 1
C Apps General Discussion 1
I Apps General Discussion 2
G Apps General Discussion 1
N Apps General Discussion 2
F Apps General Discussion 2
P Apps General Discussion 18
N Apps General Discussion 4
A Apps General Discussion 3
M Apps General Discussion 1
R Apps General Discussion 1
D Apps General Discussion 5
ak195 Apps General Discussion 1
P Apps General Discussion 15

ASK THE COMMUNITY