cascadebeer

Estimable
Feb 5, 2016
2
0
4,510
0
I have a new WD Elelment hard drive full of good movies,it will play through the tv but they are confined to a smaller screen in the middle of our tv,i have a Muteki 7.2 stereo approx 2 years old,i plugged the usb port at the front of the system and tuned to usb the tv wont reconize a thing but i have sound although broken at a steady rate.. Lost? Cheers if anyone can help.
 

SuperSoph_WD

Estimable
Jul 30, 2014
168
0
4,910
83
Welcome to the community, cascadebeer!

Can you please give us more details about your issues with the WD Elements external drive? I'd recommend you to check if you have access to your movies from a computer and also create a backup (copy the movies) to the computer. Once you do that, I'd suggest you go to Disk Management and see how your external HDD is listed there. Providing some screenshots/photos would be very helpful as well.
Once you have copied your movies and have them safe and sound somewhere else, you should try testing the WD Elements with the Data LifeGuard Diagnostics for Windows and make sure you run both the QUICK and the EXTENDED tests. The utility will help us determine the health and SMART status of the hard drive.

Keep me posted. Hope this helps you! :)
SuperSoph_WD
 
Thread starter Similar threads Forum Replies Date
J Streaming Video & TVs 3
Owain C Streaming Video & TVs 4
BiggameDave49 Streaming Video & TVs 2
Leacrocky Streaming Video & TVs 2
L Streaming Video & TVs 2
whitty500 Streaming Video & TVs 2
F Streaming Video & TVs 1
C Streaming Video & TVs 1
P Streaming Video & TVs 2
R Streaming Video & TVs 0
C Streaming Video & TVs 9
J Streaming Video & TVs 7
Z Streaming Video & TVs 4
U Streaming Video & TVs 1
M Streaming Video & TVs 3
K Streaming Video & TVs 1
J Streaming Video & TVs 1
W Streaming Video & TVs 2
F Streaming Video & TVs 2
D Streaming Video & TVs 6

ASK THE COMMUNITY