Headset microphone not working properly

Jun 8, 2018
2
0
10
0
So i got a pretty annoying problem. I own the G430 Logitech gaming headset and i've been using it for a while now without any problems. Like 2 days ago i used teamviewer with a friend and right after i closed it he told me my mic was kind of [watch your language] up. So i looked into it and i dont know why but my Mic does not even record my voice if i put it on 94 % volume boost (even tho i had on 75% before this happened and it worked perfectly). So i need to put the Volume boost really high like 98-100% to record my voice and the problem with that is that it sounds very loud and everything is ultra loud. if i talk quietly it doesnt even record my voice and you can clearly hear that there are pretty massive volume spikes when im talking, like at the beginning and ending of sentences.

I already tried deleting and redownloading the logitech gaming app and also tried setting the mic settings in windows to default.

Im using Win 10 and i have no Soundcard(dunno if that helps)

hope you can help me soon :)
 

ASK THE COMMUNITY