help with turtle beach z60 surround sound

morgan payne

Estimable
Mar 1, 2014
46
0
4,590
1
hello
as you are all aware Christmas is today and I got the z60 headset
I would like help with this 7.1 surround sound when I choose configure in the speakers in the playback settings and says this format is not supported by this device
please help
my laptop is a Dell latitude E7240

thanks a lot and im using a usb plug

morgan
 

11214888

Estimable
Feb 6, 2015
1
0
4,520
1


Hey, I'm a little late. I uninstalled the drivers for turtle beach speakers. Playback devices> rightclick 'Speakers' turtle beach> properties> properties (in the General tab) > Change settings (in the General Tab) > 'Uninstall' In the driver tab.

Then un-plug the z60 from your usb and plug it back in. If that doesn't work try doing it again but restarting your computer before you plug it back in again.
 

11214888

Estimable
Feb 6, 2015
1
0
4,520
1


Hey, I'm a little late. I uninstalled the drivers for turtle beach speakers. Playback devices> rightclick 'Speakers' turtle beach> properties> properties (in the General tab) > Change settings (in the General Tab) > 'Uninstall' In the driver tab.

Then un-plug the z60 from your usb and plug it back in. If that doesn't work try doing it again but restarting your computer before you plug it back in again.
 
May 9, 2019
1
0
10
0
Hello, after trying everything here, it still didn't work. By right clicking on the sound icon on the right bottom side of the screen you can hover over "spatial sound of", then select "windows sonic for headphones". then try enabeling 7.1 surround. It worked for me. (Using windows 10 pro)
 
Thread starter Similar threads Forum Replies Date
G Audio 4
G Audio 1
J Audio 8
Marshall Honorof Audio 1
A Audio 5
R Audio 3
Mike Andronico Audio 3
C Audio 4
Mike Andronico Audio 1
D Audio 2
A Audio 1
H Audio 6
G Audio 3
A Audio 1
L Audio 4
C Audio 1
W Audio 5
Z Audio 1
MilliaHakumei Audio 4
S Audio 1

ASK THE COMMUNITY