Hidden virus increase my cpu usage and temp

Fafaagasta

Prominent
Aug 5, 2017
7
0
510
0
Ok first of all I'm sorry if my english is bad because english is not my native language.

So, lately I noticed that when I play games with joystick (means keyboard and mouse inactive), about 15 seconds later, it will LAG so bad! Then I checked it with MSI afterburner osd, it shows 100% Cpu usage and the temp increased by 20c about 15 seconds after inactive mouse and keyboard, then, when I move the mouse or press the keyboard, the lag gone and cpu usage and temp back to normal. WTF is that! I've tried to scan viruses with Malwarebytes, antirootkit, rkill, but no change. Recently, I tried to monitoring my task manager processes while gaming (it stays on top) and after 15 seconds inactive mouse/keyboard, I saw rundll32.exe cpu usage increase so high with this lag, so I suspect the rundll32.exe after that. After that, I want to monitoring it again with task manager and speccy to see my cpu temp, but it wont show up or lag/temp increasing anymore (Like this virus is so smart that it knows I'm monitoring it) and when I close the task manager but keep speccy to see cpu temp and after 15 seconds inactive, the temp increases 20c again!!! WTF this virus trolling me!!! HELP PLEASE!!!

And one more thing, this lag/temp increase only occur when I play games on fullscreen, but when I try window mode, the lag wont come.

This is my spec
Intel Xeon X5460
Nvidia GT 1030 Asus
Ram 4gb ddr3
Motherboard Gigabyte G41MT S2
Windows 7 Ultimate 64bit
 

marksavio

Prominent
Dec 23, 2017
125
0
710
42
so you are saying if you ONLY use the joystick it will lag on windowed mode?
if you use keyboard and mouse, its normal either way?

it could be the driver for your joystick. have youy already downloaded and installed the driver for it from the manufacturers support site? what is the specific brand/model you are using?
 

Fafaagasta

Prominent
Aug 5, 2017
7
0
510
0
Well guys I solved this problem. I used Hitman Pro and it found several Trojans that Malwarebytes, Antirootkit, Rkill, didnt find. After removed those Trojans, my system back to normal and this problem never occured again. Thanks...
 
Thread starter Similar threads Forum Replies Date
A Antivirus / Security / Privacy 3
E Antivirus / Security / Privacy 1
W Antivirus / Security / Privacy 3
L Antivirus / Security / Privacy 6
W Antivirus / Security / Privacy 1
A Antivirus / Security / Privacy 7
A Antivirus / Security / Privacy 8
K Antivirus / Security / Privacy 2
L Antivirus / Security / Privacy 1
A Antivirus / Security / Privacy 3
F Antivirus / Security / Privacy 1
M Antivirus / Security / Privacy 2
G Antivirus / Security / Privacy 5
J Antivirus / Security / Privacy 1
M Antivirus / Security / Privacy 3
Z Antivirus / Security / Privacy 1
K Antivirus / Security / Privacy 3
mac29 Antivirus / Security / Privacy 1
mrfaces Antivirus / Security / Privacy 7
J Antivirus / Security / Privacy 5

Similar threads


ASK THE COMMUNITY