how to Disable internal Intel hd 520 on asus x555ub and enable gtx 940m


Dec 27, 2015
Hi so i just got the asus x555ub a few days ago and the first thing i did was install some games. Now it has 8 gigs of ram an Intel core i5 6200u and a gtx 940m so a pretty decent laptop for the price. so the first game i installed was CSGO I was running it at about 100fps on LOW settings. So then I installed some other games first company of heroes 2 I could only run on low settings at 40 fps. And I thought it might just be company of heroes. But no other games ran really bad for what this pc had. Skyrim could only run high settings at 24 fps.So I was really confused so I asked a friend who also had a similar lap top what he ran his games at. Now his laptop is a little worse then mine he said he could run csgo on all high settings at about 200fps. He was playing dying light at the time so I downloaded dying light a game I already had to see what fps I got. My friend got about 35 fps with about medium settings on 1080p. I got 30fps when I put the game on all low settings at 720p so I new something was not right. I did some research and found it might be my on integrated intel graphics being used instead of the 940 so I tried almost all the ways I could find to disable it and enable the 940. I went all through the bios nothing. I enabled it with nvida control panel no changes. Then I went to control panel and clicked mange devices. For the Graphics cards I was using the intel hd 520 as well as the 940 were enabled. So i disabled the Intel and my screen when to like 420p and it said it was using default Microsoft graphics and not using the 940. So knowing all this I need to know how to disable my intel hd 520 and enable my 940 to be used at all times. Sorry if this has been a long one with bad punctuation ext.. lol. but I need some help thanks.


You cannot disable the hd graphics, since it uses nvidia OPTIMUS technology. WIth Optimus, the descrete GPU still uses the igpu to output the finall frame to the monitor, so it's impossible to turn the HD graphics off.

Make sure you have the latest graphics driver, and right click on the game you want to play, there should be menu where you can select the "high performance NVIDIA processor", click that to use the GT 940M.

Then if you want to make that default for games (I DO NOT RECOMMEND SETTING THE NVIDIA DRIVER TO DESCRETE GPU ONLY! Leave on auto.), find the game in the nvidia control panel profiles and set that game to the high performance nvidia processor.

I hope this helps. Optimus is a pain, but it does help significantly with power savings when on the go.
Thread starter Similar threads Forum Replies Date
fotovati Laptop Tech Support 5
A Laptop Tech Support 3
K Laptop Tech Support 3
D Laptop Tech Support 2
D Laptop Tech Support 1
D Laptop Tech Support 1
N Laptop Tech Support 0
G Laptop Tech Support 4
O Laptop Tech Support 1
B Laptop Tech Support 1
R Laptop Tech Support 0
N Laptop Tech Support 1
T Laptop Tech Support 6
C Laptop Tech Support 4
S Laptop Tech Support 2
7 Laptop Tech Support 0
Z Laptop Tech Support 5
C Laptop Tech Support 1
K Laptop Tech Support 6
G Laptop Tech Support 3

Similar threads