i have a lenovo edge 15 model80k9. led power light is blinking but computer will not repond. no power up . the battery is "s

Pascale_2

Commendable
Jul 16, 2016
1
0
1,510
0
i have tried to power it up with power ac plugged in and without. on/off power button flashes white.
battery is inside "sealed" and may be difficult to access.
ran fine yesterday, shut down with 20% battery life.

if the ac plug is unplugged then i can get the led to turn off but once pushed, it ony flashes. no results

warranty is expired.
unit manufactured april 23 2015

i currently have it plugged in but no flashing light as i have not pushed the power button. im hoping that it will take a charge or correct itself with time.

what do you suggest? thank you
 
Try the following...

1. Take out (or take it off) the charger.
2. Next take out the battery
3. Now hold down power button for 20 seconds and then reinsert battery.
4. Now put it on the charger again

NOTE: Make sure charger is plugged into the main power supply (not an extension cord, surge protector, etc.)

Sometimes, when the device is not plugged in directly, it doesn't get the power it needs. Holding the power button, while you restart it, clears out the temporary ram (no it won't delete anything you have saved) and will give the device access to the ram it needs.
 
Thread starter Similar threads Forum Replies Date
Ruve Laptop Tech Support 2
L Laptop Tech Support 0
H Laptop Tech Support 0
C Laptop Tech Support 1
K Laptop Tech Support 0
K Laptop Tech Support 2
Sandis2003 Laptop Tech Support 0
M Laptop Tech Support 0
J Laptop Tech Support 1
Jayaraman K Laptop Tech Support 1
R Laptop Tech Support 4
L Laptop Tech Support 1
J Laptop Tech Support 1
navidelip Laptop Tech Support 1
leonhk Laptop Tech Support 4
K Laptop Tech Support 3
yirv iej livcnqejwvijvw Laptop Tech Support 4
Pato9097 Laptop Tech Support 0
d3mon8 Laptop Tech Support 0
chains65212 Laptop Tech Support 3

ASK THE COMMUNITY