I'm at my wits end. How can I get my .avi recordings into Vegas Pro 13 WITH the audio?

ridleyeater

Honorable
Apr 2, 2013
2
0
10,510
0
Every time that I try to import any of my recorded .avi files into Sony Vegas Pro 13, the video imports perfectly. The audio, however, is nowhere to be found. In the raw .avi recording, the audio still exists, but Vegas Pro won't bring it into my video.

I have surfed Google for far too long, and it seems that lots of people have this problem, but no one has found a solution. I don't know if I need codecs, or if I need to do something else with the files. All I know is that I want a raw recording with very little to no loss in quality when importing my .avi into Vegas Pro 13, and I want my audio to remain intact throughout the entire process.

I use FRAPS to record my footage.

Does anyone have any ideas? Because I'm fresh out of them.
 

vesp3r

Estimable
Dec 11, 2014
217
0
4,910
38
Hello, could you also tell what is the audio format of your videos? There is that problem when Sony Vegas wont recognize the audio format so i suggest you to try play a bit with that
I used both Sony Vegas and FRAPS to record videos and never had problems to add audio
At the end you might want to consider trying out vdub to compress audio and see if it will be recognized in Vegas.
Good luck!
 

vesp3r

Estimable
Dec 11, 2014
217
0
4,910
38
Hello, could you also tell what is the audio format of your videos? There is that problem when Sony Vegas wont recognize the audio format so i suggest you to try play a bit with that
I used both Sony Vegas and FRAPS to record videos and never had problems to add audio
At the end you might want to consider trying out vdub to compress audio and see if it will be recognized in Vegas.
Good luck!
 

razerg

Honorable
Nov 22, 2013
43
0
10,590
3
You might need codecs. To find out what codec you need for the file install MediaInfo http://sourceforge.net/projects/mediainfo/
Then just locate the video and it will say what codec it uses, then find that codec, download it and install it. It might help but if it doesn't it will do no harm.
 

ridleyeater

Honorable
Apr 2, 2013
2
0
10,510
0
I just fixed it. Turns out there's a feature in FRAPS where you can record multi channel sound. I had that checked instead of stereo sound. My audio now imports to Sony Vegas without any issues. Thanks for the help, everyone (even though I didn't use any of it lol). I can't believe the fix was that simple.
 
Thread starter Similar threads Forum Replies Date
T Apps General Discussion 0
Neon The (Anthro) Umbreon Apps General Discussion 3
M Apps General Discussion 4
M Apps General Discussion 8
M Apps General Discussion 1
H Apps General Discussion 4
F Apps General Discussion 1
Z Apps General Discussion 12
Requesterofhelp Apps General Discussion 1
S Apps General Discussion 2
R Apps General Discussion 1
A Apps General Discussion 4
D Apps General Discussion 2
B Apps General Discussion 6
G Apps General Discussion 6
L Apps General Discussion 2
A Apps General Discussion 1
O Apps General Discussion 1
K Apps General Discussion 6
O Apps General Discussion 2

ASK THE COMMUNITY