Interference with Modmic and Sabrent USB audio adapter

Blazzy

Commendable
Dec 24, 2016
2
0
1,510
0
First off, I am fairly illiterate when it comes to audio-lingo in general so please bear with me.
I just recently got the Modmic 4 and the Sabrent USB sound adapter to come with it. When using the Modmic alone, I get terrible static. I expected this to happen so I opted to use the sound adapter. It fixes the static, and the sound quality is much better, but it introduces some kind of interference that is just horrid. If just recording playback from the sound adapter itself, there is no noticeable interference, it is only when the Modmic is plugged in that the interference begins.

I have videos showing issues with and without the usb adapter (Have volume up):
With: https://youtu.be/Fg-tNBbnyPI
Without: https://www.youtube.com/watch?v=tAlzteroDjg (just static nothing really shocking)

Thank you for any assistance you can provide.
 

aajoe

Prominent
Sep 2, 2017
16
0
590
7
Hello @Blazzy - We recommend the Syba CM-UAUD as a third party USB sound adapter, not a Sabrent for production quality reasons. I'd basically just return the Sabrent and swap it out of the Syba and I suspect the problem will go away.

If you have additional questions you can always join our Discord and get some live help from our fans or staff: https://discord.gg/ZqDGNFg
 

aajoe

Prominent
Sep 2, 2017
16
0
590
7
Hello @Blazzy - We recommend the Syba CM-UAUD as a third party USB sound adapter, not a Sabrent for production quality reasons. I'd basically just return the Sabrent and swap it out of the Syba and I suspect the problem will go away.

If you have additional questions you can always join our Discord and get some live help from our fans or staff: https://discord.gg/ZqDGNFg
 

ASK THE COMMUNITY