Question iPhone XS 64Gb error 14

Jun 5, 2019
7
0
10
0
Hello,

When trying to update iPhone XS 64 Gb using latest iTunes from iOS 12.2 to iOS 12.3 , the update process stucked around 50% with unknown error (14 ).

Unfortunately the iTunes backup taken before the update has smaller size than expected so I need to recover all the data’s from the iPhone.

Do you have any suggestion from recovering all the data’s from the iPhone and to restore iPhone to a working state? I have to mention that I already tried using 12.2 ipsw but the same error appears
 

lmahek

Estimable
Feb 6, 2015
19
0
4,560
0
Where you doing the update via wifi or did you download the update on a pc through iTunes with your phone connected.

try this.

  1. reset your phone (and pc/Mac if updating that way).
  2. make sure time and date are correct. you may need to change your region if not.
  3. make sure iTunes is up to date.
  4. if you are running any security software make sure its up to date and if that doesn't work try cutting it off or uninstalling it.
For future reference I always recommend a hard wired connection when ever possible while doing os updates or any other critical updates. You should be updating iOS using a pc or Mac hardwired to your router. I have seen issues with phone updates done over wifi.
 
Thread starter Similar threads Forum Replies Date
Manoj Jogiya iPhone 1
W iPhone 1
Stephsniz iPhone 2
M iPhone 1
M iPhone 0
M iPhone 2
Buddhika Jayanath iPhone 0
Jduacouple iPhone 1
D iPhone 0
C iPhone 1
L iPhone 2
K iPhone 3
H iPhone 4
S iPhone 2
thepinkanator95 iPhone 8
J iPhone 1
ismail1993 iPhone 1
im15 iPhone 3
im15 iPhone 1
K iPhone 1

ASK THE COMMUNITY