key stuck on startup only

zappyguy

Commendable
Jul 22, 2016
1
0
1,510
0
Hi there,
My laptop has been acting weird lately, when I boot in windows, the non-numpad '0' key will be stuck on boot, but not in my Ubuntu boot. Although a minor annoyance, it would still be not having to deal with it every reboot. Assuming it is not a hardware problem, what steps could be taken to figure this problem out?
 
It may be a "Numlock" problem. Here are three ways to try and unlock it.


A. You can try this shortcut, press (together) the Fn + Nmlk keys.


B. You can also try disabling it in the registry...

1. Press the Windows key + R to bring up the Run box.
2. Type "regedit" and press "Enter" to open the Windows "Registry Editor".
3. In the "Registry Editor", open the following registry key.

HKEY_USER\.Default\Control Panel\Keyboard\

4. In the keyboard folder, you should see a string value named “InitialKeyboardIndicators” with a value of 0, 1, or 2. You need to change the value to 1, and you’re done.

NOTE: The Values are as follows...

0 = Num Lock is turned OFF after the logon.
1 = Disable Num Lock.
2 = Numlock is turned ON after the logon.

C. Disable NumLock in the BIOS

You can also change how your computer handles the NumLock, when the computer first boots up, through the BIOS.

1. Turn on your computer, and as soon as you see the initial POST boot screen, press the designated key for entering the BIOS Setup.
2. Locate the the “NumLock State,” “NumLock Key“, “Boot Up NumLock Status” or a similar option
3. Change the value to Disabled or Off.
4. Save your changes and exit the BIOS.
 
It may be a "Numlock" problem. Here are three ways to try and unlock it.


A. You can try this shortcut, press (together) the Fn + Nmlk keys.


B. You can also try disabling it in the registry...

1. Press the Windows key + R to bring up the Run box.
2. Type "regedit" and press "Enter" to open the Windows "Registry Editor".
3. In the "Registry Editor", open the following registry key.

HKEY_USER\.Default\Control Panel\Keyboard\

4. In the keyboard folder, you should see a string value named “InitialKeyboardIndicators” with a value of 0, 1, or 2. You need to change the value to 1, and you’re done.

NOTE: The Values are as follows...

0 = Num Lock is turned OFF after the logon.
1 = Disable Num Lock.
2 = Numlock is turned ON after the logon.

C. Disable NumLock in the BIOS

You can also change how your computer handles the NumLock, when the computer first boots up, through the BIOS.

1. Turn on your computer, and as soon as you see the initial POST boot screen, press the designated key for entering the BIOS Setup.
2. Locate the the “NumLock State,” “NumLock Key“, “Boot Up NumLock Status” or a similar option
3. Change the value to Disabled or Off.
4. Save your changes and exit the BIOS.
 
Thread starter Similar threads Forum Replies Date
Matiyo Laptop Tech Support 0
Fantamos Laptop Tech Support 10
SnackinMcCracken Laptop Tech Support 1
S Laptop Tech Support 7
D Laptop Tech Support 5
M Laptop Tech Support 3
F Laptop Tech Support 1
T Laptop Tech Support 1
I Laptop Tech Support 1
J Laptop Tech Support 1
D Laptop Tech Support 3
J Laptop Tech Support 2
J Laptop Tech Support 1
L Laptop Tech Support 1
A Laptop Tech Support 1
T Laptop Tech Support 1
M Laptop Tech Support 1
N Laptop Tech Support 1
S Laptop Tech Support 3
B Laptop Tech Support 1

ASK THE COMMUNITY