Question some keys on laptop keyboard (same with external keybord) stopped working, why?

Jul 26, 2022
1
0
10
0
My wife's laptop stared acting up the other day. She has a Samsung NP900x4c and is currently running Ubuntu.

The A S Z X C keys stopped working for her.

a clue that occurred - she saw an error message as startup about an error communicating with the TPM chip.

Now I don't recall ever using the TPM on her laptop so I tried different settings
Disable - the error message disappears
Enable - error persists
no change
enable and activate
clear
disable and deactivate

I left it disabled because I am sure I never used it after reading the manual about the TPM but it is curious that the message popped up.

None of the above made any change to the keyboard.

I tried an external keyboard and amazingly the exact same keys did not function.

Scratching my head.

I made a guess that it was Ubuntu, so I downloaded an ISO of Manjaro KDE Live and threw it on a USB drive and the problem persists.

I tried a google search like the following but the results were as you would expect, too many key words

laptop and external keyboard with same keys not working hahahahaha

Any ideas?
 

Etrius vanRandr

Prominent
May 11, 2022
363
46
470
1
My ZBook 17 has fallen off my desk from time to time when I trip over the charger which sometimes screws up the KBC.

The most likely reason for the keyboard not working is that she spilled something on it and the keys are clogged.

The second most likely reason is that the keyboard connector is loose.

You say that the same keys do not work with an external keyboard plugged in.

I want you to try something - make a Windows installer and test the keyboard in notepad while the installer is running, no need to install windows. Simply press SHIFT+F10 at any point during the setup to launch Command Prompt, from which you can launch Explorer and Notepad.

The third possible reason is that Ubuntu somehow was configured to ignore or not recognize those keys specifically.
 
Thread starter Similar threads Forum Replies Date
Jirky Laptop Tech Support 0
MonkeyZki Laptop Tech Support 0
Satish3409 Laptop Tech Support 3
Mathias Aivasovsky Laptop Tech Support 1
chaplark Laptop Tech Support 1
B Laptop Tech Support 1
R Laptop Tech Support 5
G Laptop Tech Support 3
J Laptop Tech Support 1
C Laptop Tech Support 1
M Laptop Tech Support 4
IceMacIOP Laptop Tech Support 1
S Laptop Tech Support 3
D Laptop Tech Support 4
anthonyorm Laptop Tech Support 7
M Laptop Tech Support 2
S Laptop Tech Support 2
K Laptop Tech Support 1
E Laptop Tech Support 7
G Laptop Tech Support 1

ASK THE COMMUNITY