Question Laptop CPU stuck at 0.4 GHz

Aug 4, 2021
I've got a problem with my Swift 3 laptop and I've spent a couple of hours searching for a solution, to no avail.

I have a Swift SF314-41 (N17W7) which has a Ryzen 3500U CPU.

The problem started yesterday without any obvious changes (no Windows updates, no damage, no new software, etc) and is now happening 100% consistently.

The problem is that shortly after a boot, or shortly after waking from sleep, the CPU gets stuck at 0.4 GHz, no matter what I am doing. This makes everything run excruciatingly slowly. Using Task Manager > Performance I can see that the total CPU usage is never higher than 19%, and it's often flat-lined at 19% in the graph.

It happens for both battery and AC power supply.

If I put it to sleep then wake it up, it will run at up to about 2.6 GHz for around 20-30 seconds, then it gets stuck back at 0.4 and doesn't go up again.

I've tried the battery reset via paperclip method but that had no effect on the problem.

I've checked the BIOS for any fan readings, but didn't find any. Oddly I can't hear a fan and I'm not sure I've ever heard a fan running in this laptop. Does it even have one? No software I've tried seems to show a fan speed, and fan speeds are all missing from tools like HWMonitor, Notebook FanControl, and a few others.

CPU temperature according to HWMonitor is around 60-80 degrees, but since the CPU can't work harder than 0.4 GHz it doesn't really seem to warm up any more than that, so I'm wondering if I don't hear the fan simply because it's not getting hot enough. The CPU temperature sensor seems to be operational and sane.

I've checked my Power settings in Windows and the maximum CPU performance is set to 100% for both battery and AC power. Minimum was set to 0% but I tried raising that and it didn't seem to make any difference.

I'm sure the AC power supply is working because I can see the laptop charging normally when it's connected.

I'm at a bit of a loss about this! What could it be?
Aug 4, 2021
Update: I've used an external fan and conduit to cool the CPU down to 30C, thinking maybe it's thermally throttling, perhaps due to a main fan failure, but even at 30C it's still throttling down to 0.4 GHz.
Sep 12, 2021
I had similar issue with my ASUS X512DA, CPU usage stuck at 19%.
I just opened up laptop and remove the processor Heat Sink and cleaned up the old Thermal Paste and applied new one and everything works fine.
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 2
Arash.jahd Laptop Tech Support 0
John21903 Laptop Tech Support 2
J Laptop Tech Support 1
jasonkariuki98 Laptop Tech Support 1
C Laptop Tech Support 1
Plagu3Dr Laptop Tech Support 2
Unkn0wnUs3r Laptop Tech Support 0
buzzybabii_1 Laptop Tech Support 1
P Laptop Tech Support 0
SkiBaBopBaDopBop Laptop Tech Support 1
beejayel30 Laptop Tech Support 0
Komla Laptop Tech Support 4
T Laptop Tech Support 2
D Laptop Tech Support 1
dietherdeyv Laptop Tech Support 0
Matiyo Laptop Tech Support 0
C Laptop Tech Support 1
HumanPerson12 Laptop Tech Support 0
Farros Taufiqur Rahman Laptop Tech Support 4