Laptop is always laggy while watching Netflix, fine with everything else

Dan Kweed

Commendable
May 1, 2016
4
0
1,510
0
So I am using an HP EliteBook 8540p running Windows 8.1 Pro. I try not to use it too much (about 4 hours a day max, often not at all) but before me it was used as a work laptop at a hospital. I would guesstimate that it's about 3-4 years old and in good condition.

As you can tell by the title, Netflix never seems to work properly on here. It's not the WiFi or Ethernet Cable as I have tried both and every other product I use works fine. I assume it's not the laptop because everything else works fine, I play League of Legends which I would think takes alot of computer power and it works decent but no major problems. Youtube, twitch.tv, twitter/facebook, live sports streaming, everything else I can think of, aside from the inability to run most Steam games there are no problems at all.

To clarify, Netflix.com works fine, I can browse through the catalog no problem but as soon as I click play on a show or movie it's almost instant lag where my laptop has to skip frames and I sometimes can't even follow the mouse until I try to find the close button or ctrl+w out of the tab.

This seems to only be an issue with Netflix. I have another older slower laptop that can hardly run League at all but streams Netflix fine.

I have tried to research potential solutions for this but it was too difficult to find people in my exact situation that also provided solutions. So I simply ask, what are the steps I can take to try and run Netflix without any problems?

Some notes.
according to beta.speedtest.net/
ping: 16 ms
download: 110.50 mbps
upload: 11.80 mbps

The processor: Intel(R) Core(TM) i5 CPU M 520 @ 2.40 GHz
RAM: 4 GB (3.86 GB usable)

I hope this helps and I appreciate any assistance you are able to provide.
 

Dan Kweed

Commendable
May 1, 2016
4
0
1,510
0


I couldn't find the resolution settings, but I did realize that I was only trying it on Chrome. I tried it on Internet Explorer and oddly enough it worked fine as far as I saw, despite the bad rep it gets. It'll have to do considering I have the same problem on Firefox.
 
Thread starter Similar threads Forum Replies Date
prattbetta@ Laptop Tech Support 0
prattbetta@ Laptop Tech Support 0
prattbetta@ Laptop Tech Support 1
C Laptop Tech Support 1
M Laptop Tech Support 0
N Laptop Tech Support 1
S Laptop Tech Support 3
J Laptop Tech Support 1
C Laptop Tech Support 1
A Laptop Tech Support 4
A Laptop Tech Support 1
S Laptop Tech Support 3
M Laptop Tech Support 5
SeekNDstroy Laptop Tech Support 2
T Laptop Tech Support 3
S Laptop Tech Support 2
S Laptop Tech Support 1
B Laptop Tech Support 1
B Laptop Tech Support 8
Z Laptop Tech Support 4

ASK THE COMMUNITY