Laptop Keys Suddenly Glitching (Repeating and not working!)

JordiFrancis

Commendable
Aug 2, 2016
2
0
1,510
0
I turned my laptop on today, and I soon noticed that some of the keys are not working properly. These include the 'm' key - sometimes if I press it, it doesn't work at all. Other times, I'll press it once and two or three 'm's will appear. I get the latter problem with the comma key and the full stop key. The shift keys work fine (they capitilise letters and work fine for other keys) however, pressing the comma key+shift should type '<', however, it does not. The same with the full stop key+shift and the '>' character. Also, the '/' key works perfectly fine, but when I hold /+shift to input the question mark character, it doesn't appear.

This has all happened out of nowhere. I don't think it's a hardware issue, due to the / key working fine and the shift keys working fine, but the question mark not working, and also the other discrepancies.

I have essays due soon and work to do, and this is very frustrating. Please help!
 
It may be a "Numlock" problem. Here are three ways to try and unlock it.


A. You can try this shortcut, press (together) the Fn + Nmlk keys.


B. You can also try disabling it in the registry...

1. Press the Windows key + R to bring up the Run box.
2. Type "regedit" and press "Enter" to open the Windows "Registry Editor".
3. In the "Registry Editor", open the following registry key.

HKEY_USER\.Default\Control Panel\Keyboard\

4. In the keyboard folder, you should see a string value named “InitialKeyboardIndicators” with a value of 0, 1, or 2. You need to change the value to 1, and you’re done.

NOTE: The Values are as follows...

0 = Num Lock is turned OFF after the logon.
1 = Disable Num Lock.
2 = Numlock is turned ON after the logon.

C. Disable NumLock in the BIOS

You can also change how your computer handles the NumLock, when the computer first boots up, through the BIOS.

1. Turn on your computer, and as soon as you see the initial POST boot screen, press the designated key for entering the BIOS Setup.
2. Locate the the “NumLock State,” “NumLock Key“, “Boot Up NumLock Status” or a similar option
3. Change the value to Disabled or Off.
4. Save your changes and exit the BIOS.
 
Thread starter Similar threads Forum Replies Date
awesomeballer69 Laptop Tech Support 0
R Laptop Tech Support 3
J Laptop Tech Support 2
N Laptop Tech Support 6
S Laptop Tech Support 13
R Laptop Tech Support 4
S Laptop Tech Support 2
C Laptop Tech Support 1
A Laptop Tech Support 4
M Laptop Tech Support 1
N Laptop Tech Support 3
I Laptop Tech Support 1
P Laptop Tech Support 3
C Laptop Tech Support 1
B Laptop Tech Support 4
N Laptop Tech Support 1
L Laptop Tech Support 1
R Laptop Tech Support 4
A Laptop Tech Support 1
S Laptop Tech Support 2

ASK THE COMMUNITY