Laptop switches to integrated graphics sometimes when in game

Apr 3, 2018
7
0
10
0
When I play games such as Fortnite and League of Legends, my laptop slows down and the fps drops significantly where it should be 100+ it goes to ~30. This has been occuring since the beginning of March. I replaced my motherboard, updated all drivers, reinstalled windows, removed any malware, set preferred graphics to Nvidia, but the problem still occurs. How can I fix this?

My laptop is a Dell XPS 15 9560 with GTX1050, 16gb ram, i7700HQ, 512 ssd.
Here is an image from task manager during the slowdown:
http://prntscr.com/j02clq
CPU Temps:
http://prntscr.com/j02etf
 
Apr 3, 2018
7
0
10
0


I already have the latest BIOS (1.8.1), even the dell site only has the 1.7.1 BIOS update.
 

kookie3010

Honorable
Sep 3, 2013
806
0
12,010
167


wait so dell pull the 1.8.1 bios?i face the same issue before with my 7567 where i updated to the latest bios and few days after dell pull the bios update from their site due to certain issue.
 
Apr 3, 2018
7
0
10
0


I am not sure if they pulled it, but I have the 1.8.1 bios. Should i try to downgrade my bios back to 1.7.1?
 

kookie3010

Honorable
Sep 3, 2013
806
0
12,010
167


if the bios is no longer available on dell site i think they might have pull it down.i say give it a try.
 
Apr 3, 2018
7
0
10
0


So i changed the bios back to 1.7.1, but the problem is still there. It didn't fix anything.
 
Apr 8, 2018
4
0
20
1


Is all ur power options on max performance?
And image settings and 3d options
If worst comes to worst just disable the Integrated graphics(use as last ditch)



 
Apr 3, 2018
7
0
10
0


I don't see why I would have to do that since my laptop is relatively new and still under the 1 year warranty. I've brought it to my IT department multiple times, but they weren't able to permanently fix the problem. They got it to work by changing some power settings but then the next day it stopped working again.
 
May 26, 2018
1
0
10
0
This was happening to me on my Alienware 15 (GTX 970M)
I changed my settings in the Nvidia Control panel and that fixed it
Nvidia Control Panel: 3D Settings, Set to High Performance Nvdia Processor, Apply
Physx Config: Set to your Nvidia 1050, Apply
And set your laptop to High Performance when gaming
This personally fixed it for me I was have the same issue whilst playing Fortnite, So hopefully this'll work for you to. Hopefully I'm not too late :)
 
Thread starter Similar threads Forum Replies Date
maybeits_jack Laptop Tech Support 2
iAdarsh Laptop Tech Support 13
B Laptop Tech Support 1
A Laptop Tech Support 2
R Laptop Tech Support 1
A Laptop Tech Support 1
M Laptop Tech Support 1
L Laptop Tech Support 1
B Laptop Tech Support 1
S Laptop Tech Support 1
R Laptop Tech Support 1
C Laptop Tech Support 1
S Laptop Tech Support 2
E Laptop Tech Support 1
K Laptop Tech Support 1
H Laptop Tech Support 1
A Laptop Tech Support 1
M Laptop Tech Support 2
Ordan Laptop Tech Support 2
S Laptop Tech Support 5

ASK THE COMMUNITY