Laptop using integrated graphics and not dedicated

Matt_163

Commendable
Jan 4, 2017
19
0
1,570
1
I just bought the Lenovo Idepad 510 that has a GTX940mx in it, but when I loaded GTA 4 it said I had 512mb of Vram instead of 4gb. I went into Nvidia control panel and clicked preferred graphics render and clicked high end. I went back into GTA 4 and it still wont work. Please help.
 

Sedivy

Commendable
Dec 17, 2016
92
0
1,660
32
Hmm. There are people talking about issues with vram with that game and forcing allocation of certain amount from within game. Might want to try:
http://steamcommunity.com/app/12210/discussions/0/864960354015410539/
to see if it affects performance or if it'll switch to using the card if you up the limit.
Another link suggests the same:
https://support.rockstargames.com/hc/en-us/articles/200145206-Issues-with-GTA-IV-showing-video-cards-with-over-2GB-as-under-spec
that basically it is using your video card but for some reason isn't registering its full memory. Same solution as previous link.
 

Sedivy

Commendable
Dec 17, 2016
92
0
1,660
32
https://support.serato.com/hc/en-us/articles/202305784-Changing-graphics-card-settings-to-use-your-dedicated-GPU-on-a-Windows-computer-
Follow points 5-8
 

Matt_163

Commendable
Jan 4, 2017
19
0
1,570
1


Didnt work, thank you though. I contacted lenovo and they said it was supposed to automatically switch for me.
 

Sedivy

Commendable
Dec 17, 2016
92
0
1,660
32
That's rather odd. If you specify within your nvidia control panel that both global and program specific settings should use the video card and it's not using it, I can only think that from within the game or perhaps steam, there is a way to select for it and for some reason it's not doing it. I can't see why it would bypass it otherwise.
When you open your device manager, you do register the card right? You see the drivers installed and no error signs?
 

Matt_163

Commendable
Jan 4, 2017
19
0
1,570
1


For some reason, GTA 4 uses my integrated graphics, but other games use my 940mx. Not sure why this is either. Also, shouldnt Black Ops 1 run a lot better than 1080p medium settings 45-60 fps?
 

Sedivy

Commendable
Dec 17, 2016
92
0
1,660
32
Well...on a 940m I would say that's about right, considering it's a laptop for BO1. But your GTA is doing something off. Maybe a lack of driver optimizations or ..hum. I really don't know. GTA4 forums don't mention anything about this?
 

Matt_163

Commendable
Jan 4, 2017
19
0
1,570
1


I mean GTA 4 runs decent on my integrated graphics, theres just frame drops now and then. I think I can live with it.
 

Sedivy

Commendable
Dec 17, 2016
92
0
1,660
32
Hmm. There are people talking about issues with vram with that game and forcing allocation of certain amount from within game. Might want to try:
http://steamcommunity.com/app/12210/discussions/0/864960354015410539/
to see if it affects performance or if it'll switch to using the card if you up the limit.
Another link suggests the same:
https://support.rockstargames.com/hc/en-us/articles/200145206-Issues-with-GTA-IV-showing-video-cards-with-over-2GB-as-under-spec
that basically it is using your video card but for some reason isn't registering its full memory. Same solution as previous link.
 
Thread starter Similar threads Forum Replies Date
M Laptop Tech Support 5
Jph5674 Laptop Tech Support 2
C Laptop Tech Support 1
E Laptop Tech Support 1
S Laptop Tech Support 1
P Laptop Tech Support 3
Y Laptop Tech Support 3
virtualflying Laptop Tech Support 3
L Laptop Tech Support 1
A Laptop Tech Support 1
A Laptop Tech Support 11
A Laptop Tech Support 11
F Laptop Tech Support 8
M Laptop Tech Support 2
S Laptop Tech Support 5
S Laptop Tech Support 1
Z Laptop Tech Support 5
R Laptop Tech Support 1
Q Laptop Tech Support 3
A Laptop Tech Support 1

ASK THE COMMUNITY