Laptopkeyboard spam key only when i play games

Lukas_10

Commendable
Apr 22, 2016
6
0
1,510
0
Hello, a couple of months ago i wanted to drink coffee while working on laptop and i spitt on the keyboard one of those milk doses you put in coffee ( its a small thing with condensed milk, its like 5ml) and since then my keyboard didnt worked anymore, i put my laptop upside down for 24h then it would just spam the letter "1-!" and bought a wireless keyboard as a work-around, the lap[top keyboard was still spamming it and i found out that if i press that button hard it would stop for a couple of hours, recently it started spamming button 2 only when im playing games for some reason, if i exit a game and wait a minute it would stop, i got a few programs that remapps keys or disable them, it works but when i get back in a game it starts again to spam number 2 even if i remap it to "home" for example, i dont know what to do. Please help and sorry for my poor english.

EDIT:
OS: windows 8.1 pro
RAM: 8GB DDR3
VIDEO: Nvidia GT 540m 1GB
CPU: i3 380m
Packard bellEasyNote TK85
 
Hi, if you disable the keyboard in the device manager, Windows installs the driver at the next boot, it's not a good idea. You must disconnect and remove the keyboard, if you still have the same problem, the liquid is already on motherboard and giving the erratic behavior.
 
Hi,

Water or any liquid is the enemy of laptops and other electronic devices. Here are some troubleshooting steps that may help.
- First, do open the laptop and make sure that there's no more spills inside the laptop.
- Next, if you want to just use the wireless keyboard for your laptop you just disable the built in keyboard.
- Open Device Manager then right click on the keyboard driver and select Disable.
- Once done, do test your wireless keyboard again and see if the same problem will persist or not.
- Another suggestion is to take the laptop to a local PC repair shop to make sure that there's no other liquid inside the laptop.
- And lastly, replace the keyboard itself with a new one.

Here's a replacement keyboard for your laptop.
https://www.amazon.co.uk/TK37-TK81-TK83-TK85-TX86-black/dp/B00H9EM6W0?ie=UTF8&*Version*=1&*entries*=0
 

Lukas_10

Commendable
Apr 22, 2016
6
0
1,510
0



Hello, thank you for the fast reply, i tried to disable it via device manager but it never saves, it tells me to restart for it to make effect but once i restart it and check device manager its enabled, i even tried to use a program called "devmanview" which its supose to disable it for good which it didnt work either. I invested enough money for this laptop and i dont want to pay again a huge amount of money again for this so im trying to find a solution to disable it at lest, i dont care that i use a wireless keyboard but all i want is to get rid of the build in to stop doing random ****.
 
Hi, if you disable the keyboard in the device manager, Windows installs the driver at the next boot, it's not a good idea. You must disconnect and remove the keyboard, if you still have the same problem, the liquid is already on motherboard and giving the erratic behavior.
 
Thread starter Similar threads Forum Replies Date
RespectedRobert Laptop Tech Support 2
hubertkocur1337 Laptop Tech Support 2
ina_dee Laptop Tech Support 7
T Laptop Tech Support 6
maryano1096 Laptop Tech Support 9
Ghostspartis Laptop Tech Support 2
IsaacSmith423 Laptop Tech Support 7
M Laptop Tech Support 3
D Laptop Tech Support 7
A Laptop Tech Support 1
V Laptop Tech Support 1
S Laptop Tech Support 4
3 Laptop Tech Support 0
R Laptop Tech Support 0
Y Laptop Tech Support 3
safwanvanila Laptop Tech Support 1
S Laptop Tech Support 2
S Laptop Tech Support 1
RegisZDB Laptop Tech Support 1
H Laptop Tech Support 1

ASK THE COMMUNITY