Lenovo Blu-Ray Ultrabay problems?

TheSwampDonkey5

Honorable
Aug 26, 2013
1
0
10,510
0
Hi Guys I recently bought a Lenovo Y500 with Blu-Ray ultrabay but it is giving me problems. It played a blu-ray fine the first time I used it but when I wanted to import a cd into I-tunes the burn cd process started.
In fact I cannot even explore a disc in the drive without this process starting? Now it will not even play a blu-ray?
Does anybody have a fix for this as contacting Lenovo support is not as streamlined as it could be. Regards
 

mauller07

Distinguished
Mar 28, 2010
249
0
18,960
35
remove the software that's causing the conflict.

i would remove all lenovo branded software from the machine as it tends to be crapware and cause all sorts of problems.
 

mauller07

Distinguished
Mar 28, 2010
249
0
18,960
35
remove the software that's causing the conflict.

i would remove all lenovo branded software from the machine as it tends to be crapware and cause all sorts of problems.
 
Thread starter Similar threads Forum Replies Date
asxxs Laptop Tech Support 1
S Laptop Tech Support 1
Ket09 Laptop Tech Support 1
S Laptop Tech Support 1
J Laptop Tech Support 1
Iamkiaei Laptop Tech Support 1
S Laptop Tech Support 3
N Laptop Tech Support 1
kassuba39 Laptop Tech Support 2
P Laptop Tech Support 2
R Laptop Tech Support 1
C Laptop Tech Support 10
E Laptop Tech Support 3
L Laptop Tech Support 5
D Laptop Tech Support 4
R Laptop Tech Support 6
A Laptop Tech Support 7
C Laptop Tech Support 4
H Laptop Tech Support 3
I Laptop Tech Support 6

ASK THE COMMUNITY