Lenovo x131e Chromebook not starting after write-protection switch toggled

St4tch

Commendable
Apr 6, 2016
1
0
1,510
0
Hello,
I tried to make my chromebook into a Linux machine - but I fear that will not happen. I went through the entire process of removing the keyboard etc, and finally moved the switch. However, upon pressing the power button......nothing. Nothing with just the battery, nothing with just AC power, nothing at all. Can anyone point me in the right direction? is there something I missed? Or is this perfectly good laptop just dead weight now?
Thanks.


Edit: I have taken it apart to what I did before, and put it back together, not missing any connections, still nothing.
 

Steve Simons

Estimable
May 31, 2014
27
0
4,610
6
Were you grounded when you did this. Static electricity is a bad thing.

I'm guessing it's that or a missed connection. Chromebooks have a pretty finicky seating on some of those ribbons. Check those, they shouldn't pull out easily if seated properly.
 
Thread starter Similar threads Forum Replies Date
Roger- BiTNET Laptop Tech Support 0
T Laptop Tech Support 0
C Laptop Tech Support 0
J Laptop Tech Support 1
cia23 Laptop Tech Support 0
A Laptop Tech Support 0
Loreeeh_ Laptop Tech Support 9
Mvnch Laptop Tech Support 0
Semilore kaj Laptop Tech Support 0
Kraktom1 Laptop Tech Support 0
roystons Laptop Tech Support 0
N Laptop Tech Support 1
nerdyotter Laptop Tech Support 0
I Laptop Tech Support 1
9amk Laptop Tech Support 1
L Laptop Tech Support 0
C Laptop Tech Support 3
S Laptop Tech Support 1
B Laptop Tech Support 2
A Laptop Tech Support 2

ASK THE COMMUNITY