Lenovo Y510p red pixels in black color

MadBlitz

Honorable
Oct 11, 2013
3
0
10,510
0
Screen flickered once and red pixels appeared in place of black color. I connected to an external monitor through VGA and to TV through HDMI, both external displays are fine. Even lenovo logo at start up and bios menu has this problem.Next morning I turned on the laptop it was fine and then afternoon problem appeared again after gaming. I took screenshots with print screen and viewed it on phone they are fine. I dont know what the problem is exactly. Screen, cable, gpu port which connects the screen....?

windows



[video="https://www.youtube.com/watch?v=j-RdHQt4sCY&feature=youtu.behttps://www.youtube.com/watch?v=j-RdHQt4sCY&feature=youtu.be"][/video]

Lenovo logo at Bios



ubuntu



Also, every morning the screen will be fine again, I can even use it for normal tasks for long periods without any issue but If I play a game for 1-2 hours or more the screen problem will reappear and I have to wait until next morning.

screenshots took using printscreen and phone camera when screen problem reappeared

Printscreen




printscreen photos using phone camera




 
Thread starter Similar threads Forum Replies Date
T Laptop Tech Support 1
S Laptop Tech Support 1
H Laptop Tech Support 4
K Laptop Tech Support 1
I Laptop Tech Support 8
P Laptop Tech Support 1
T Laptop Tech Support 1
K Laptop Tech Support 11
D Laptop Tech Support 3
R Laptop Tech Support 1
C Laptop Tech Support 3
P Laptop Tech Support 2
J Laptop Tech Support 1
T Laptop Tech Support 3
M Laptop Tech Support 1
P Laptop Tech Support 1
H Laptop Tech Support 2
B Laptop Tech Support 1
W Laptop Tech Support 1
S Laptop Tech Support 5

ASK THE COMMUNITY