lenovo yoga 510 works really slow even after reinstall

edddyyysss

Estimable
Feb 22, 2014
14
0
4,560
0
Hi there,

So suddenly one day, my current laptop - lenovo yoga 510 (4gb ram, i3 processor, 125 gb ssd) started to work really slow. So I did fresh Windows 10 install, but the problem still persists the same. What could be the problem? I have done clean with the ccleaner, check task manager nothing suspicious. Any ideas?
 

velo3100

Distinguished
Moderator
Does this happen all the time or when windows defender or window update runs. I know that windows defender and update make laptops slow as it uses your hdd a lot. Also 4 gigs of ram is not much for windows 10. Also chrome is a resource hog, try using firefox.
 

edddyyysss

Estimable
Feb 22, 2014
14
0
4,560
0
When the update is not running or defender it's faster but it's still sluggish. I will try Firefox instead. But previously didn't have any problem like this.
 

edddyyysss

Estimable
Feb 22, 2014
14
0
4,560
0
I installed all drivers but it still was the same. Then I went on power option and clicked on 'high performance' now even processing go pro video, my small laptop works really fast. Would be that a case or just a luck (windows stopped installing updates)?
 

velo3100

Distinguished
Moderator
It could be that you were you using the balanced power profile which will change the performance depending on what you are doing whereas High performance will always give you the max performance regardless of the task.
 

baneen.usman

Prominent
Aug 22, 2017
1
0
510
0
Guys I am here with the same problem, my lenovo laptop (brought recently) has gone super slow.. i havent installed or changed any thing and had an expectation, since its new laptop it should not get slow or require computers geek thingies to keep it fast (shame on lenovo if layman have to go to forums to find solution as their laptops are getting slow them selves ) any ways .. I have checked and tried all solutions, page filing size increasing, high performance, disc scans, defregments, malware detection, closing or stopping apps at startup, advanced power setting and moving it to maximum for all categories etc etc but no use .. i have windows 10, what should i do ?
 

aseager13

Prominent
Aug 22, 2017
1
0
510
0
Had the same problem on my Lenovo. Turned out to be the Lenovo preinstalled software. One of the programs was making my disk usage run at 100%, slowing everything down. Uninstalling all of the Lenovo factory installed software fixed it for me
 

frepetto

Prominent
Nov 10, 2017
1
0
510
0


Hi, could you please tell me what you exactly did step by step? I have the same issue. Even after the restore.
What are the precise applications that you removed?
Thanks for the response.