Logitech C920 webcam not working properly

thanatomic26

Estimable
Mar 8, 2015
1
0
4,510
0
Right, so I bought my C920 second-hand off eBay, which, admittedly, was not the best idea. Anyway, having plugged it in and installed the latest drivers, I go to use it in a Skype call and it works for a moment then disconnects. The blue indicator light just flashes and goes off.

After a few seconds, the webcam reconnects, but it's not recognised by my PC. I can try a different USB port, but the problem persists. I even tried a different system, but to no avail.

Now I hope I'm right in saying that because the webcam works momentarily, it's either the cable or the driver that's the problem and not the camera itself. Any help would be greatly appreciated and if you need any other info just ask.

Many thanks.
 

yumri

Distinguished
Sep 5, 2010
22
0
18,570
1
really it sounds like you bought a faulty camera as yes it seems like it is a the cable on the line that handles the data transmitting at least
 
Thread starter Similar threads Forum Replies Date
U Digital Cameras 1
T Digital Cameras 3
D Digital Cameras 2
R Digital Cameras 3
E Digital Cameras 1
PhilipMichaels Digital Cameras 1
R Digital Cameras 1
D Digital Cameras 2
K Digital Cameras 4
TechyInAZ Digital Cameras 1
G Digital Cameras 1
The_Icon Digital Cameras 4
THwh Digital Cameras 4
a39232 Digital Cameras 1
G Digital Cameras 1
H Digital Cameras 1
T Digital Cameras 1
S Digital Cameras 2
JMcEntegart Digital Cameras 1
K Digital Cameras 1

ASK THE COMMUNITY