Logitech G930 Microphone Echo? Unfixable?

Status
Not open for further replies.

amsage

Estimable
Mar 15, 2014
4
0
4,510
0
Recently purchased one of these headsets. The mic on this thing echos like crazy! I can hear almost every ambient noise piped through the headphones. The worst is that my voice, when I speak, comes through full volume on a half-second delay, which is extremely distracting when trying to talk.

Their support forums offered 2 possible solutions: Turn the Sidetone setting in the softrware down to 0. Did that, it didn't help. The 2nd solution was to make sure the Mic was not acting as a playback device. Frankly, I don't know enough about audio to know how to do that.

Logitech phone support was virtually useless. The rep told me to make sure the headphones were the default speaker, the mic was the default playback, and to try plugging it in to a different USB port before just giving up and telling me it was a defective headset.

I'm able to return to Amazon no problem, but I figured I'd come here and see if there were any suggestions first before I go headset-less for another week or two : (

I'm using Windows 7 (x86)
 

ttimberlak443

Honorable
Jan 11, 2014
129
0
10,760
35
I have found that the G930's can be a rather buggy headset, although they are decent when they are working properly. I would try unistalling/reinstalling and drivers and software that you are using. You could also try using them without any Logitech drivers installed and see if that does anything. If memory serves me well, Windows will still see them as their own sound device in the sound manager even without the Logitech Gaming Software installed.

I don't think that there is much to be done besides return it to Amazon. If you spend time on the phone with Amazon, they will send out a truck for your headset. When they get the confirmation that it was picked up, that is when they send out the new one. The downtime should only be a few days tops.

That is the exact process that I went through when I got a DOA set of Sennheiser PC360's, so I would assume that it would be no different for the G930's as long as it was purchased through Amazon and not a 3rd party seller.
 

ttimberlak443

Honorable
Jan 11, 2014
129
0
10,760
35
I have found that the G930's can be a rather buggy headset, although they are decent when they are working properly. I would try unistalling/reinstalling and drivers and software that you are using. You could also try using them without any Logitech drivers installed and see if that does anything. If memory serves me well, Windows will still see them as their own sound device in the sound manager even without the Logitech Gaming Software installed.

I don't think that there is much to be done besides return it to Amazon. If you spend time on the phone with Amazon, they will send out a truck for your headset. When they get the confirmation that it was picked up, that is when they send out the new one. The downtime should only be a few days tops.

That is the exact process that I went through when I got a DOA set of Sennheiser PC360's, so I would assume that it would be no different for the G930's as long as it was purchased through Amazon and not a 3rd party seller.
 

michealrp

Distinguished
Jan 12, 2012
1
0
18,510
0
I realize that this is an older post, but in case someone else is having a similar issue, try turning down the "sidetone" setting within the Logitech software equalizer section. Sliding it all the way down will disable it completely. It's designed to allow you to slightly hear yourself as these are muffs and will cut down your normal ability to hear your voice as you would when speaking normally.
 
Jan 28, 2016
1
0
4,510
0



This is exactly what worked, amazing thank you. I know its old but this was the problem for me thanks!
 

Monica_14CompTech

Commendable
Jul 27, 2016
2
1
1,510
0


I do have an option for you...although I'm posting an answer to a 2 year old post, maybe someone else may come along and need the answer, so, here are the steps to follow;

Use these settings if using Windows 7
1.Open Sound by clicking the Start button , and then clicking Control Panel. In the search box, type sound, and then click Sound.

2.Click the Recording tab, click Microphone, and then click Properties.

3.Click the Listen tab, remove the check from the Listen to this device check box, and then click OK.

Use these settings if using Windows 10
1.Clicking on the search bar next to the Windows symbol, then type "Sound" (without quotes),

2.Click on the first option at the top that says "Audio" then the word "Control Panel" under it.

3.Once you've pulled up the "Audio" box, you'll see your audio device listed. Double click on that device

4. Click on the "Recording" tab at the top, then select the "Microphone" you are using. Then click on "Properties" the click on the tab that says "Listen". Check to see if there is a check mark in the box that says "Listen to this Device", if so, uncheck the box, click on "Save" or "Apply" or "OK" and then click on "Apply".

Good Luck! I hope this solves your problem!!



 
Reactions: eijuma2

Ace_Acer

Commendable
Sep 29, 2016
1
0
1,510
0


To your solution i will add this for those who need to do some recording with commentaries and who could have some troubles with this solution(like the sound of the voice not being recorded) - Some recording softwares offers the possibility to mix 2 sound sources into 1 sound track(like bandicam for example) and by selecting the headset as secondary source the voice is recorded and there is no echo while recording.

Also, if echoing persists while streaming there is a small option in the "Custom" tab of the microphone properties called "AGC"(Automatic Gain Control) and it's checked by default. Un-checking it has the side effect of reducing the echo if the "Listen to this device" box is checked. Finally if you have both a set of speakers and a headset with microphone i suggest unplugging the speakers completely. Some wireless phones (landline type) can also interfere with the microphone and make you sound like a robot.
 

Mick_7

Commendable
Oct 29, 2016
1
0
1,510
0


You, sir, are a legend. This fixed it on my G930 after several hours looking around on the internet.

Apologies for the necro, I just wished to thank this poster.
 

NaZeLNoFF

Commendable
Dec 10, 2016
1
0
1,510
0


I`ve found the real problem! TURN THE FEEDBACK ALL THE WAY DOWN, and you wont hear your own voice:D:D:D
 
Status
Not open for further replies.

ASK THE COMMUNITY