Logitech G930 won't play sound

thekylelegs

Estimable
Jan 3, 2016
2
0
4,520
1
I have the driver software installed and it picks up my mic. The headphones are my default playback audio device but I am not hearing anything coming from them. The mic works and will send data but I cannot hear things. I have uninstalled and installed the software a couple times and still nothing. The bars next to the headset in the sound tab( to select default device) do not move or bump up at all even when a video or something that should produce audio is playing. I am on windows 10 64 bit. This problem has started after I upgraded from my HDD to an SSD and also upgraded my CPU's heat sink. When I change the default audio device to something else (Realtek) and go into the volume mixer and select the headphones, when I move the volume I can hear that on my headset though. But if I change the default device back to the headset I hear nothing.

Thank you, please help
 

thekylelegs

Estimable
Jan 3, 2016
2
0
4,520
1
I figured it out myself, ended up uninstalling it again but installed with a older version. I was on 8.76 but everything is working now with 8.58.
Thanks
 

GeGeFTF

Estimable
Dec 29, 2015
1
0
4,510
0
I have the same issue, I can use my headset (G930) only on Skype or comunication apps but it won't produce any other sound. It started since I upgraded to Windows 10. "thekylelegs" said an interesting thing but I don't know how to get the the older software
 
Thread starter Similar threads Forum Replies Date
B Audio 2
deusman Audio 2
C Audio 1
Q Audio 6
K Audio 1
7 Audio 1
D Audio 2
M Audio 3
P Audio 1
M Audio 2
L Audio 1
A Audio 5
F Audio 3
J Audio 6
M Audio 1
H Audio 2
A Audio 1
R Audio 1
W Audio 1
C Audio 1

ASK THE COMMUNITY