Logitech Z906 popping sound

Aug 17, 2018
1
0
10
0
Hello.
First of all, my english is not the best.
Yesterday I bought new speakers, the Logitech Z906
Since yesterday evening, everytime when I turn them on,
the speakers make a "popping" sound. Everything is connected and they work perfectly.
What causes the popping sound (Its 100% not my soundcard, because it doesnt matter if something is connected to the subwoofer or not) and is it dangerous for the speakers?
 

dudio

Admirable
It's not uncommon for there to be a pop when the amp first turns on.
I personally leave my 4.1 speakers powered on all the time, and I've had them
for over 15 years. Just feel under the sub (where the amp is located) to confirm there
is little to no heat when they're not doing anything.
Either way, I wouldn't be concerned that something is wrong.
 

dudio

Admirable
It's not uncommon for there to be a pop when the amp first turns on.
I personally leave my 4.1 speakers powered on all the time, and I've had them
for over 15 years. Just feel under the sub (where the amp is located) to confirm there
is little to no heat when they're not doing anything.
Either way, I wouldn't be concerned that something is wrong.
 
Thread starter Similar threads Forum Replies Date
david.molnaar Audio 0
B Audio 4
laeddis Audio 0
deusman Audio 2
K Audio 2
A Audio 5
H Audio 2
R Audio 0
Scoope Audio 1
L Audio 2
Ausbeancounter Audio 3
DionL Audio 1
SmokeMeowt Audio 3
JoshBedroom Audio 2
Jhact Audio 1
TwistedFury Audio 4
Nigh Audio 3
T Audio 4
Cromat88 Audio 1
glockshna Audio 3

ASK THE COMMUNITY