Low framerate on "new" "gaming" laptop... CS:GO.

ProbablyNeedHelp

Commendable
Jul 11, 2016
6
0
1,510
0
Hey! So I've been a PC gamer for a long time now, I only recently brought a laptop for light gaming, unfortunately I have been having some issues with CS:GO, I run everything on it's lowest settings at 1920x1080 (I can't stand non-native resolution stretching.) so I am getting around 30-50 fps! With nothing on screen, during battles, explosions and other stuff, I drop into the low 20s, any ideas on what I can do to get a higher framerate? There is no overheating and the specs will be below:

Operating System
Windows 10 Home 64-bit
CPU
Intel Core i3 3110M @ 2.40GHz 57 °C
Ivy Bridge 22nm Technology
RAM
6.00GB Dual-Channel DDR3 @ 665MHz (9-9-9-24)
Motherboard
Type2 - Board Vendor Name1 VA70_HC (U3E1) 55 °C
Graphics
Generic PnP Monitor (1920x1080@40Hz)
Intel HD Graphics 4000 (Acer Incorporated [ALI])
1023MB NVIDIA GeForce GT 630M (Acer Incorporated [ALI]) 41 °C
ForceWare version: 353.54
SLI Disabled
Storage
465GB Hitachi HTS545050A7E380 (SATA) 34 °C
Optical Drives
Slimtype BD E DS4E1S
Audio
High Definition Audio Device

Thanks in advance!
 

STEEV0

Commendable
Jul 10, 2016
1
0
1,510
0
If you're trying to run this game on the native resolution (1920x1080), you will struggle to get above 60fps with these specs. One thing to look into would be to see if the computer is using the integrated or dedicated graphics card to play the game. If its using the integrated graphics, you will get lower framerates. If you go to nvidia control panel, go to manage 3D settings, global settings and set preferred graphics processor to 'high performance nvidia processor' to use the 630M instead of the Intel HD. Fyi, if you are using the laptop on battery power to play the game it will automatically select the Intel HD instead of the 630M. You can't change this, so play plugged in. You also say SLI disabled in your post, if there is another card, use it. Also, you screen refresh rate is at 40hz, if you change that in control panel to 60Hz things might look a bit smoother.

Hope this helps a little.
 

Hekarizblade

Honorable
Oct 8, 2013
7
0
10,510
0
Try reducing the resolution about 720p just be stuck there or maybe the Intel graphics is running than the Nvidia that's laptop does these days.
 

ProbablyNeedHelp

Commendable
Jul 11, 2016
6
0
1,510
0


Is it actually possible to make a 40Hz screen run at 60Hz, I didn't think that would be possible, also it is using the 630M, does "SLI Disabled" mean I have 2 cards but one is disabled, that is super weird...
 

Miltoid19

Estimable
Dec 30, 2015
5
0
4,520
1


The "SLI Disabled" probably means that it runs ether the Intel HD Graphics 4000 (probably not) or the 1023MB NVIDIA GeForce GT 630M. Also, you mast be able to change to 60Hz since screens from 2001 were supporting that refresh rate. About the low fps, it's probably because the PC is using the Intel HD card so change it to the nvidia from the power setting.
 

ProbablyNeedHelp

Commendable
Jul 11, 2016
6
0
1,510
0


It is definitely using the GT 630m and I have changed it to 60Hz, in other news, Nvidia GeForce Experience, optimised the game, with higher settings, no sense, but its somehow running better with higher settings, any explanation? Thanks btw :)
 
Thread starter Similar threads Forum Replies Date
B Mobile Gaming 2
theBigBig Mobile Gaming 0
E Mobile Gaming 0
M Mobile Gaming 0
A Mobile Gaming 1
P Mobile Gaming 1
Stephsniz Mobile Gaming 7
L Mobile Gaming 1
P Mobile Gaming 1
P Mobile Gaming 3
L Mobile Gaming 1
P Mobile Gaming 1
S Mobile Gaming 5
J Mobile Gaming 1
S Mobile Gaming 10
K Mobile Gaming 3
minnie_mouse Mobile Gaming 9
L Mobile Gaming 1
A Mobile Gaming 3
N Mobile Gaming 3

ASK THE COMMUNITY