Medion Erazor charging problem

NUFCAC

Distinguished
Mar 12, 2009
4
0
18,510
0
I have a Medion Erazer X7821, which doesn't charge correctly.When it is plugged it charges intermittently. It wont work without the battery when plugged in.

Recently a red light has been appearing on the battery charge indicator. Laptop is about a year and a half to two years old. I have tried contacting Medion but they are terrible and have had no response.

I thought it may have been an overheating problem which would shut off the charging to prevent overheating. the laptop has shut of on its own 3 times over the last month or so.

The problem has been going on for a good few months, possibly 6 to 8.

In order to charge I have to leave it plugged in over night and even then it doesn't charge fully. When the lid is shut the battery charge indicator flashes randomly.

Any ideas?

Any help would be gratefully received.

Many thanks.
 

NUFCAC

Distinguished
Mar 12, 2009
4
0
18,510
0
No I haven't, it started to go wrong after less than a year so I thought it was unlikely to be the battery. It wasn't used every day at that time. I am however now looking at replacing the battery but was just checking that there wasn't something which I was overlooking.

Thanks for the reply by the way.
 
Thread starter Similar threads Forum Replies Date
palinmike Laptop Tech Support 0
chippy-mx Laptop Tech Support 2
T Laptop Tech Support 2
A Laptop Tech Support 1
R Laptop Tech Support 1
L Laptop Tech Support 2
U Laptop Tech Support 2
M Laptop Tech Support 1
B Laptop Tech Support 1
H Laptop Tech Support 9
W Laptop Tech Support 1
J Laptop Tech Support 2
J Laptop Tech Support 1
E Laptop Tech Support 1
N Laptop Tech Support 3
NOOB2PRO Laptop Tech Support 1
NOOB2PRO Laptop Tech Support 1
J Laptop Tech Support 1
steven10101989 Laptop Tech Support 1
M Laptop Tech Support 4

ASK THE COMMUNITY