MSI GL62m turned off while running as if battery died, would not turn back on, only shows blue battery light

flentum

Prominent
Jan 13, 2018
1
0
510
0
I tried the trick that seems to come up for this that involved taking the battery out, plugging the charger in after holding the power button then adding the battery back in and nothing changed

Tried removing the RAM and putting back, in both slots

The blue battery light will turn on and off after holding the power button for a few seconds with both the battery and charger plugged in, nothing happens without the charger

Nothing looks damaged

Not under warranty
 
NOTE: Yes, I know some batteries are not so easy to get to, on some devices. However, it should be removable/replaceable. Unless it is under warranty, then you should contact the manufacturer first.


Try the following and see if it will turn on...

1. Unplug your charger cord.
2. Remove the battery.
3. Press and hold the "Power" button for 30 seconds.
4. Now plug back in the power/charger cord.
5. Now put the battery back in.

If this doesn't help, then test the power cord to see if it is good. Either try your cord in another device, or try another devices cord in your laptop. You may also want to try charging it when the device is off, rather than on. If it works then, the cord is probably the issue.

Should that not be the problem, then check the battery to see if it needs replacing.

 
NOTE: Yes, I know some batteries are not so easy to get to, on some devices. However, it should be removable/replaceable. Unless it is under warranty, then you should contact the manufacturer first.


Try the following and see if it will turn on...

1. Unplug your charger cord.
2. Remove the battery.
3. Press and hold the "Power" button for 30 seconds.
4. Now plug back in the power/charger cord.
5. Now put the battery back in.

If this doesn't help, then test the power cord to see if it is good. Either try your cord in another device, or try another devices cord in your laptop. You may also want to try charging it when the device is off, rather than on. If it works then, the cord is probably the issue.

Should that not be the problem, then check the battery to see if it needs replacing.

 
Thread starter Similar threads Forum Replies Date
Anjul Laptop Tech Support 0
O Laptop Tech Support 1
L Laptop Tech Support 1
Kalmartin Laptop Tech Support 2
D Laptop Tech Support 2
D Laptop Tech Support 0
A Laptop Tech Support 0
S Laptop Tech Support 8
J Laptop Tech Support 1
Gadour Laptop Tech Support 2
L Laptop Tech Support 7
K Laptop Tech Support 3
crypix Laptop Tech Support 1
A Laptop Tech Support 1
M Laptop Tech Support 1
P Laptop Tech Support 1
D Laptop Tech Support 3
X Laptop Tech Support 1
S Laptop Tech Support 14
M Laptop Tech Support 6

ASK THE COMMUNITY