Question MSI GS60 Laptop won't turn on after cleaning fans. Front LED lights up for 10 seconds then turns off. No sounds of fans or components.

Jun 28, 2020
1
0
10
0
I decided to clean my laptop yesterday and boy was there ALOT of dust. Anyway after getting the interior nice and shiny. (I cleaned the fans with a soft toothbrush and rubbing alcohol, then used a air blower to dry it out the fans from any left over alcohol.

I made sure everything was completly dry. Anyway, after assembling it back together, I plug in the power adapter and the LED indicating it's charging the battery is on, but when I click the power button nothing happens except for another LED (looks like a moon, probably sleep mode?) turns on for about 10 seconds then turns off.

Nothing else is happening, no screen, no sounds from fans, no sound from HDD. What could be the culprit?

- I took the RAM out from each slot twice one for each ram and tried to turn it on to no avail.

- Tried holding the power button for 30 seconds. Nothing.

What else can I try? Is there a way to narrow down the problem?
 

CJb_432

Distinguished
Jul 6, 2013
13
0
18,560
0
Remove the battery for a minute and hold the power button for a few seconds, then test. If that doesnt work reset/ clear your bios. Your laptop might have a small button to press with a paperclip on the side OR you will have to open it up and unplug the bios battery.
 
Thread starter Similar threads Forum Replies Date
--juliana-- Laptop Tech Support 8
B Laptop Tech Support 9
J Laptop Tech Support 9
F Laptop Tech Support 3
E Laptop Tech Support 1
C Laptop Tech Support 8
J Laptop Tech Support 3
M Laptop Tech Support 1
J Laptop Tech Support 3
T Laptop Tech Support 3
Q Laptop Tech Support 3
C Laptop Tech Support 16
L Laptop Tech Support 2
E Laptop Tech Support 1
S Laptop Tech Support 1
L Laptop Tech Support 1
N Laptop Tech Support 7
S Laptop Tech Support 3
P Laptop Tech Support 1
P Laptop Tech Support 3

ASK THE COMMUNITY