My keyboard types wrong characters

Redeker2

Commendable
Oct 15, 2016
3
0
1,510
0
Three of my keyboard buttons are typing wrong characters, namely T=GT, F=RF and Enter=+. You can now clearly see how uncomrforgtable igt is. Irf anygthing, I didn'gt pour any liquid on my lapgtop. GThe problem began yesgterday and never happened gto me berfore. Any solution?
+
My laptop is Alienware 17, I tried holding fn + numlock, but it did not work. On-screen keyboard works perrfectly. Also, if I continiously press these buttons, they keep writing the right letter.
 
Well, it could be the individual keys, it could be the numlock, or the keyboard itself.
NOTE: If anything got in it. Liquid, food, etc., then it could cause them to do more than one at a time. If this is the case, you would need to clean it out.

To check the Numlock...

A. You can try this shortcut, press (together) the Fn + Nmlk keys.

B. You can also try disabling it in the registry...

1. Press the Windows key + R to bring up the Run box.
2. Type "regedit" and press "Enter" to open the Windows "Registry Editor".
3. In the "Registry Editor", open the following registry key.

HKEY_USER\.Default\Control Panel\Keyboard\

4. In the keyboard folder, you should see a string value named “InitialKeyboardIndicators” with a value of 0, 1, or 2. You need to change the value to 1, and you’re done.

NOTE: The Values are as follows...

0 = Num Lock is turned OFF after the logon.
1 = Disable Num Lock.
2 = Numlock is turned ON after the logon.

C. Disable NumLock in the BIOS

You can also change how your computer handles the NumLock, when the computer first boots up, through the BIOS.

1. Turn on your computer, and as soon as you see the initial POST boot screen, press the designated key for entering the BIOS Setup.
2. Locate the the “NumLock State,” “NumLock Key“, “Boot Up NumLock Status” or a similar option
3. Change the value to Disabled or Off.
4. Save your changes and exit the BIOS.


If not that, try this... Then you can try turning off the laptop, connecting an external keyboard, and turning on the laptop. If that one gives you no problems, then there is something going on with the attached buttons/keyboard.
 
1. Go to "Control Panel" and then click on "Device Manager".
2. In this new window locate and click once to open the "Keyboards" section.
3. Next right click on your listed keyboard and select "Properties".
4. Now in this window you want to click on the "Driver" tab.
5. On this screen click "Uninstall".
6. Once it is done click "OK" and then close all the windows.
7. Reboot the computer and it should install the driver when it restarts.
 
Well, it could be the individual keys, it could be the numlock, or the keyboard itself.
NOTE: If anything got in it. Liquid, food, etc., then it could cause them to do more than one at a time. If this is the case, you would need to clean it out.

To check the Numlock...

A. You can try this shortcut, press (together) the Fn + Nmlk keys.

B. You can also try disabling it in the registry...

1. Press the Windows key + R to bring up the Run box.
2. Type "regedit" and press "Enter" to open the Windows "Registry Editor".
3. In the "Registry Editor", open the following registry key.

HKEY_USER\.Default\Control Panel\Keyboard\

4. In the keyboard folder, you should see a string value named “InitialKeyboardIndicators” with a value of 0, 1, or 2. You need to change the value to 1, and you’re done.

NOTE: The Values are as follows...

0 = Num Lock is turned OFF after the logon.
1 = Disable Num Lock.
2 = Numlock is turned ON after the logon.

C. Disable NumLock in the BIOS

You can also change how your computer handles the NumLock, when the computer first boots up, through the BIOS.

1. Turn on your computer, and as soon as you see the initial POST boot screen, press the designated key for entering the BIOS Setup.
2. Locate the the “NumLock State,” “NumLock Key“, “Boot Up NumLock Status” or a similar option
3. Change the value to Disabled or Off.
4. Save your changes and exit the BIOS.


If not that, try this... Then you can try turning off the laptop, connecting an external keyboard, and turning on the laptop. If that one gives you no problems, then there is something going on with the attached buttons/keyboard.
 
Thread starter Similar threads Forum Replies Date
B Laptop Tech Support 2
P Laptop Tech Support 1
C Laptop Tech Support 8
F Laptop Tech Support 4
P Laptop Tech Support 1
N Laptop Tech Support 1
J Laptop Tech Support 4
J Laptop Tech Support 1
P Laptop Tech Support 3
S Laptop Tech Support 1
K Laptop Tech Support 3
M Laptop Tech Support 1
K Laptop Tech Support 1
S Laptop Tech Support 1
S Laptop Tech Support 4
C Laptop Tech Support 1
T Laptop Tech Support 1
V Laptop Tech Support 1
Chakky Laptop Tech Support 1
N Laptop Tech Support 3

ASK THE COMMUNITY