My Nvidia 740M doesn't appear on the Device Manager or on the Bios (Laptop)

derikbacon

Commendable
May 29, 2016
1
0
1,510
0
Hi all!

I have a problem with my laptop's gpu. My Nvidia 740M doesn't appear on the Device Manager. It just shows the integrated gpu Intel HD Graphics 4000. I've also checked on the BIOS setup but I couldn't neather found it there.



I downgraded from Win10 to Win7 trying to test if it was a driver problem but it neither works on Win7. When I try to install the Nvidia drivers it says this:



I've tried many many things, I don't know what else I could do or even if the nvidia stills alive.

My laptop is a Toshiba satellite pro c50-a-1hq, running temporally right now on win7 x64, want to return to win10 asap.

Thank you very much for your help.
 
Hi,

You've pretty much done all the possible troubleshooting steps that should have resolved the issue but it's starting to look like a hardware problem. Please do try doing a clean install of the GPU driver and see if that will help or not.

http://www.tomshardware.com/faq/id-2767677/clean-graphics-driver-install-windows.html

If all these will not work I would suggest taking it for a repair since the GPU might have died already.
 
Thread starter Similar threads Forum Replies Date
N Laptop Tech Support 1
A Laptop Tech Support 1
S Laptop Tech Support 1
Z Laptop Tech Support 1
N Laptop Tech Support 1
K Laptop Tech Support 1
A Laptop Tech Support 3
M Laptop Tech Support 7
C Laptop Tech Support 4
P Laptop Tech Support 3
E Laptop Tech Support 1
A Laptop Tech Support 1
J Laptop Tech Support 4
M Laptop Tech Support 15
Thenightmare12 Laptop Tech Support 11
1 Laptop Tech Support 4
1 Laptop Tech Support 1
S Laptop Tech Support 1
N Laptop Tech Support 3
V Laptop Tech Support 15

ASK THE COMMUNITY