Solved! My rca tablet shows a battery sign with lightning bolt but won't turn on

Oct 20, 2018
Trouble shooting rca tablet shows battery with lightning bolt won't turn on tried holding down power and volume up button also tried reset button
That lightning bolt is usually a sign of charging (when plugged in).

NOTE: Yes, I know some tablet batteries are not so easy to get to, on some devices. In such a case, make sure that your tablet is not under warranty still before you try opening it up yourself. If it is under warranty, then contact the manufacturer first.

Try the following and see if it will turn on.

1. Remove the battery.
2. Press and hold the "Power" button for 20 seconds.
3. Now put the battery back in.
4. Plug it in to charge and allow it to fully charge before turning it on.

If this doesn't help, then test the charger cord to see if it is good. Either try your cord in another device, or try another devices cord on your device.

Should that not be the problem, then check the battery to see if it needs replacing.

If you still can't get it working, and if it isn't under warranty, then I would try a local tech.
Thread starter Similar threads Forum Replies Date
johnf52 Android Tablets 1
C Android Tablets 1
ReallyTastyApples Android Tablets 0
TaroBeni Android Tablets 4
StudyHacks Android Tablets 1
T Android Tablets 1
E Android Tablets 2
N Android Tablets 1
A Android Tablets 1
A Android Tablets 1
T Android Tablets 1
S Android Tablets 1
D Android Tablets 1
S Android Tablets 1
N Android Tablets 1
P Android Tablets 1
B Android Tablets 1
B Android Tablets 1
D Android Tablets 4
L Android Tablets 1
Similar threads
Solved! I have a Cambridge Sciences tablet that is stuck showing the word Android at boot up.
Solved! RCA 10 Viking Pro Tablet - did factory reset, still shows has stopped
Question Hey! My Onn tablet keeps showing the loading screen, turning off, and then turning on repeatedly on a cycle, what do I do!?
Question I need help, My tablet (rca voyager rct 6973w43), just show me the logo an after a message red letter that says Bootloader error code 1 when turn on
Question Wifi doesn't show up on Tablet
Solved! My Dodson tablet was charging and it just went off and now it is as dead as a doornail it's dose not show the little battery t
Solved! How to fix tablet won't come on unplugged but battery shows full charge
My Verizon Ellipsis 7's Screen shattered about a year ago and it worked for three months Before it only showed the bottom of t
My simban picasso tablet 10' is not coming on its showing a battery sign with a triangle in the battery sign with a question m
My Rca Android tablet modelRCT6K03W13 on't turn on It says it is fully charged the charge on will show but when I try to r it
On my Toshiba tablet it shows wifi connection, but will not connect to any app, I'm losing my mind. If anyone has any help tha
I have samsung galaxy tablet A android version 5.1.1 but when I download the app HOTSTAR .IT IS INSTALLED BUT SHOWING THIS AP
when i turn on my tablet it only shows the irulu icon and goes off again
my tablet wont show a screen after the logo loads
My samsung tablet is just showing its logo and not turning on
my tablet do not show it charging after connected to charger
LG V700 Tablet.. Black screen though battery indicator shows 100%
My rca tablet want charge. I've bought brand new chargers. An all it will show is like a yield sign with a battery an a explor
I've had my tablet charging for over an hour now and it won't turn on. It doesn't even show the battery charging loading scree
Samsung tab3 not showing battery percentage