Not able to use the nvidia graphics card in my system

Finnegan5

Prominent
Jun 30, 2017
1
0
510
0
So I have a acer aspire E5-573G-56RG and it has a intel i5 5200u and a 940m. I was feeling as if I am not getting the peformance a 940m should be getting. And because of this I was making sure I had the right graphics selected when I went into steam and it says nvidia graphics but when I change my graphics to intel hd it is the exact same fps, I also tried disabling intel hd graphics. And now I can't load into games and can't go into my nvidia control panel ( it says you aren't currently using a display attached to a nvidia graphics card). which leads me to believe that I can only use intel graphics for some reason. I hav tried downloading the acer graphics driver but I am not sure if I did it right and it isn't working Please help me.
 
Laptop using other graphics card and not the Nvidia one?

First you need to get it to detect and use the right card.

A. Uninstall, and then reinstall, the latest graphics card driver.
B. Make sure that your Nvidia graphics card is set as the default graphics card.

Here's the steps on how to set it to default.

1. Open the "Nvidia Control Panel".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance Nvidia processor.

Once it is running on the right one, test the system again and see if the problem persists.
 
Laptop using other graphics card and not the Nvidia one?

First you need to get it to detect and use the right card.

A. Uninstall, and then reinstall, the latest graphics card driver.
B. Make sure that your Nvidia graphics card is set as the default graphics card.

Here's the steps on how to set it to default.

1. Open the "Nvidia Control Panel".
2. Select "Manage 3D Settings" under 3D Settings.
3. Click on the "Program Settings" tab and select the program you want to choose a graphics card for from the drop down list.
4. Now select "preferred graphics processor" in the drop down list. (You can see what the automatic option is listed as global setting) If you want to use the dedicated graphics card, select High-performance Nvidia processor.

Once it is running on the right one, test the system again and see if the problem persists.
 
Thread starter Similar threads Forum Replies Date
Georgeop799 Laptop Tech Support 2
Jph5674 Laptop Tech Support 2
Uditbh Laptop Tech Support 0
A Laptop Tech Support 1
M Laptop Tech Support 1
D Laptop Tech Support 0
U Laptop Tech Support 1
Nitesh Poonia Laptop Tech Support 1
AmazonTheGamer Laptop Tech Support 1
M Laptop Tech Support 2
A Laptop Tech Support 1
H Laptop Tech Support 1
L Laptop Tech Support 1
G Laptop Tech Support 3
P Laptop Tech Support 1
M Laptop Tech Support 3
K Laptop Tech Support 5
D Laptop Tech Support 1
A Laptop Tech Support 4
G Laptop Tech Support 27

ASK THE COMMUNITY