Onkyo TX-SR373 not working on Samsung Nu7100

Aug 9, 2018
1
0
10
0
So here is my problem
I just bought a new Samsung Nu7100 65" , Onkyo TX-SR373 and a 24' rocketfish 4kHDR hdmi cable. My receiver is in a built in shelf and my tv is above the fireplace. I connected everything up and made sure I was in the ARC ports and everything was on. I connected up my STB and started getting the audio through the speakers but the signal was terrible. I got a quick picture flashed up then nothing but the audio. I played with the connections with no luck. I decided to directly connect the tv to the stb and it looks great. I even tried my BD player from receiver to tv and nothing. Anyone able to help me figure out my problem?
 
Can you get the receiver set up menu on the TV? Did you do the receiver set up?
Any 24" HDMI cable can be a big problem with the wrong combination of receiver and TV. Even if the cable works for the set top box the receiver might not work with that cable.
Try connecting the receiver to the TV with a short cable.. If you already ran the cable and can't replace it there are boosters that you can add.
https://nerdtechy.com/best-hdmi-signal-amplifier-boosters
 
Can you get the receiver set up menu on the TV? Did you do the receiver set up?
Any 24" HDMI cable can be a big problem with the wrong combination of receiver and TV. Even if the cable works for the set top box the receiver might not work with that cable.
Try connecting the receiver to the TV with a short cable.. If you already ran the cable and can't replace it there are boosters that you can add.
https://nerdtechy.com/best-hdmi-signal-amplifier-boosters
 
Thread starter Similar threads Forum Replies Date
DaveintheCave Audio 0
B Audio 0
L Audio 3
R Audio 2
Conbrue Audio 1
A Audio 3
B Audio 1
R Audio 5
C Audio 1
PLBoucher Audio 7
Loudsoothesmind Audio 2
S Audio 1
T Audio 0
M Audio 0
gediman Audio 2
N Audio 1
diesel888 Audio 1
M Audio 1
P Audio 4
T Audio 3

ASK THE COMMUNITY